locked
"One or more parameters were not specified for the subreport " Error is encountered RRS feed

  • Question

  • I am creating a subreport with 3 parameters i. e 

    ParameterA internal with default value

    ParameterB visible 

    ParameterC visible 

    I am setting the values for parameter 'ParameterB' and 'ParameterC' from main report as I can't set the value for 'ParameterA' as it is internal and it should pick the default value if not set.  However while running the master report,  subreport is throwing error as "One or more parameters were not specified for the subreport" 

    When I am changing the parameter visibility for 'ParameterA' to visible and setting the value for it from main report , subreport is running fine although I don't want to change the visibility for 'ParameterA'

    Please let me know if I am missing something.

    Thursday, May 23, 2013 7:20 AM

Answers

  • Hi Kapgup,

    This error message indicates that you havnen’t specfiy all the parameter values for your subreport, I would suggest you to open the subreport properties window,and pay attention to the Parameters section, verify whether you had feed values for each parameters of your subreport.

    I have tested it on my environment (SQL Server Reporting Services 2008 R2, Window 7), we cannot reproduce this issue. If the parameter's default has been specificed and we not specific value to this parameter to run this report, then the default value will be used to run this report.

    Reference:Add a Subreport and Parameters (Report Builder and SSRS)

    Regards,


    Charlie Liao
    TechNet Community Support

    • Marked as answer by Charlie Liao Thursday, May 30, 2013 2:52 AM
    Friday, May 24, 2013 8:48 AM