none
Sharepoint 2013 Designer Workflow: Set/Update a Multi-User field from another Multi-User field RRS feed

  • Question

  • I am trying to set a User/Group Field which allows multi selection on a library item from a similar field (User with multi selection) on a Workflow Task List Item in the SharePoint 2013 Designer workflow.

    If I return the Source field as User ID's, Separated by Semicolon and set the Destination Field, it is only saving the First User instead of all the users in that field.

    I tried creating a simple workflow variable and formatted that variable in "ID;#DisplayName;#ID;#DisplayName#ID;#DisplayName" format and used that variable to set the Destination field. But this time the Field didn't save any values.

    What is the best way to set a Multi-User Field in a SharePoint Designer Workflow?

    Platform: SharePoint Server 2013

    Tool: SharePoint Designer 2013

    Friday, March 10, 2017 5:18 PM

All replies

  • Hi,

    Please select return field as: "Login Names, Semicolon Delimited". I create a SharePoint 2013 designer workflow and use the Update List Item action to update a list item value.

    See the screenshot below:

    Or please install the latest update for SharePoint 2013, then check if it works.

    https://technet.microsoft.com/en-us/library/mt715807(v=office.16).aspx#BKMK_2013

    Or please provide more details about how to reproduce this issue, others would get easier to research on it.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 13, 2017 2:40 AM
    Moderator
  • Hi Dennis,

                  Thank you for your response. I did exactly the way you showed it in your screenshots. But it is not working as expected. To give you more details.

    1. Create two Site Columns of type User and allow multiple selections. UserField1 & UserField2

    2. Add the two fields(UserField1,UserField2) to a Custom List(List 1) and Document Library (Library1)

    3. Create a SPD 2013 Workflow on the List1 & Library1 and in the workflow just update the value of UserField2 from UserField1

    4. Create a New item in the List1 & Library1 and set the UserField1 values to multiple Users. Let the workflow run and verify if the UserField2 was updated with all the values from UserField1.

    In my case the UserField2 got updated correctly on a List Item(List1) but not on the Document List Item(Library1)

    Not sure if it is a bug in SP 2013. I have tried the Login Name's, Email Address's and User Id's. None of them worked for a Library Item.

    Friday, March 24, 2017 9:03 PM
  • Hi Kranthi,

    I tried using source MultiUser Field as "String" and is worked just fine on library. Please see screenshots below. (Copied field from UsersA field to UsersB Field)


    Saturday, March 25, 2017 6:13 AM