locked
Need a clean start. How to uninstall VS2015? RRS feed

  • Question

  • I've been installing and reinstalling VS multiple times. The first time worked but I accidently "broke" it when doing a modify with the setup app. I've tried repairing, uninstalling and reinstalling but it won't work again. Any instructions on how to remove VS Community and its components+registry so no trace is left on it when I install it again?

    Any help is appreciated. :)


    David98xp

    Friday, September 25, 2015 8:36 PM

Answers

  • @David,

    Please remember to backup your registry before you delete them. 

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by David98xp Wednesday, September 30, 2015 11:47 PM
    Wednesday, September 30, 2015 1:51 AM

All replies

  • @David,

    May I know details about "but I accidently "broke" it ", how you modified the setup app? Have you manually delete anything in your setup?

    If so have you ever tried to re-download the setup and make sure you have already verified the ISO checksum?

    Normally if we want to remove Visual Studio completely, we have to remove with the original setup, for example vs_ultimate.exe /uninstall /force In this way all Visual Studio related components will be removed. But it won't affect the registries. I am not aware of such a tool to move the registry.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Barry Wang Monday, September 28, 2015 1:21 PM
    Monday, September 28, 2015 1:19 PM
  • I had the same problem with VS Enterprise 2015. I installed it and it worked great, but after I upgraded my VS 2013 to SP 5, VS 2015 stop working. It kept giving me all sorts of errors. I tried modifying it in the control panel, but eventually I had to uninstall it and then re-install it. Finally, I re-installed it using the custom installation, checking all the parameters I needed manually, afterwards I had to go into the extension manager and gather all the extension add-ons I needed.

    It's been working great after that.

    DinoAllen

    Monday, September 28, 2015 2:12 PM
  • @David,

    May I know details about "but I accidently "broke" it ", how you modified the setup app? Have you manually delete anything in your setup?

    If so have you ever tried to re-download the setup and make sure you have already verified the ISO checksum?

    Normally if we want to remove Visual Studio completely, we have to remove with the original setup, for example vs_ultimate.exe /uninstall /force In this way all Visual Studio related components will be removed. But it won't affect the registries. I am not aware of such a tool to move the registry.

    Best regards,

    Barry




    Cheers! I'll try the cmd uninstall. I'll delete the registry VS files and then I'll try a reinstall.

    David98xp

    Monday, September 28, 2015 10:27 PM
  • @David,

    Please remember to backup your registry before you delete them. 

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by David98xp Wednesday, September 30, 2015 11:47 PM
    Wednesday, September 30, 2015 1:51 AM