none
SharePoint 2013-Error while restoring site collection backup from prod to dev RRS feed

  • Question

  • Hi ,

    I have to restore production backup to QA/dev server, I have backup using powershell but now when I restoring the same on test/dev, It's giving me the error, I have tried below scenario's

    Not worked-> Try to restore prod backup to test/dev

    Not Worked-take backup of test one site collection and restore it on another site collection on same farm
    worked-backup of site and then restore it on same site

    I have checked all things like patching and CU, both prod and test having same configuration, what could be the issue?

    PS C:\Windows\system32> Restore-SPSite -Identity "site_url" -Path "_path"  -force
    
    Confirm
    Are you sure you want to perform this action?
    Performing operation "Restore-SPSite" on Target "site_url".
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): a
    Restore-SPSite : <nativehr>0x80070003</nativehr><nativestack></nativestack>
    At line:1 char:1
    + Restore-SPSite -Identity "site_url" - ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...dletRestoreSite:SPCmdletRestoreSite) [Restore-SPSite], D
       irectoryNotFoundException


    Vishal Goyal



    • Edited by MS_21212 Wednesday, April 26, 2017 1:51 PM
    Wednesday, April 26, 2017 10:10 AM

All replies

  • Sound like, you were passing wrong site url. Might be your passing webapplication name rather than site collection.

    Why don't you go for Mount and demount content database rather than back up and restore. Take back up of production content database and restore into UAT db server. Run following commands in PowerShell.

    $SiteUrl = "Desintation url"
    $CurrentContentDatabase = "contentdbname"
    $NewContentDatabase = new content db name
    $DatabaseServer = "DB server"
    Dismount-SPContentDatabase -Identity $CurrentContentDatabase -confirm:$false
    Mount-SPContentDatabase -name $NewContentDatabase -DatabaseServer $DatabaseServer -WebApplication $SiteUrl -confirm:$false

    ---------------------------------------------------------------------------------

    ----------------------------------------------------------------------------

    Thanks

    Lalith

    ----------------------------------------

    Please mark as Answer, if this post solves your issue.


    Wednesday, April 26, 2017 4:23 PM
  • Hi Vishal,

    May I know update on this?

    Wednesday, May 3, 2017 1:39 AM