none
Disable display Mixed Content pop-up without using IE enabling/disabling option RRS feed

  • Question

  • Problem Statement:

    Need to remove “Display mixed content” pop-up on browsing a website without using IE enabling/disabling option.

     

    Detail Description:

    We have migrated an application deployed on old server with IIS 6.0 to new server with IIS 7.5.

    New server has a load balancer which routes HTTP request to HTTPS in website URL. But web.config of application refer another URLs which work with HTTP and not with HTTPS

    and thus “Display mixed content” pop-up appears.

     

    Please provide some resolution for the same ASAP. There are following conditions:

    1. URLs referred in web.config can’t be changed to HTTPS:// because some of them do not work with HTTPS.
    2. We can’t use IE enabling/disabling option.(http://msdn.microsoft.com/en-us/library/ie/ee264315%28v=vs.85%29.aspx)
    3. We don’t have access to configure Load balancer.
    4. Changing https:// to http:// in code base is not preferred.
    5.   We do not have rights to edit “Require SSL” setting in IIS. Currently, it is disabled.

    Also we tried this resolution given below, but it is not working in our case

    http://vasupra.wordpress.com/2010/08/11/silverlight-display-mixed-content/

    Please provide some resolution urgently.

    Thursday, April 11, 2013 6:04 PM

All replies