locked
Hyper-V Emulators Problem RRS feed

  • Question

  • I am trying to run a simple project (C#/Windows/Universal) on any one of the 5 available Mobile Emulators on Visual Studio 2015, Community Edition, but the emulator does not work and it gives an error message as follows:

    [Window Title]
    Windows Phone

    [Content]
    The emulator is unable to set the VHD on the virtual machine:

    Couldn't change Virtual hard drive of the virtual machine: 'Mobile Emulator 10.0.10240.0 720p 5 inch 1GB.marios' failed to add device 'Virtual Hard Disk'. (Virtual machine ID ________-____-____-____-____________)

    The storage where the virtual hard disk is located does not support virtual hard disk sharing.

    'Mobile Emulator 10.0.10240.0 720p 5 inch 1GB.marios': Cannot get information for attachment 'C:\Users\Marios\AppData\Local\Microsoft\XDE\10.0.10240.0\dd.720x1280.1024.vhd'. (Virtual machine ID________-____-____-____-____________)

    The storage where the virtual hard disk is located does not support virtual hard disk sharing.

    [Close]

    Any input on how to deal with this, will be of great assistance. 

    Many Thanks.

    Saturday, August 15, 2015 1:32 PM

Answers

  • Problem solved !

    Solution uninstall Hyper-V (restart pc) and reinstall it (restart pc).   That's it.   All emulators in Visual Studio worked 100% after doing this today.    (Control Panel\Programs\Programs and Features\Turn Windows Features On or Off: Untick Hyper-V)

    I had done this process from the very first day I had this issue, and several times afterwards, but it did not yield any results during these previous attempts.    Today however it did the job.  Apparently a couple of days ago Microsoft released some new virtualization features for Windows 10, and probably in there was the solution to my problem.  Its a bit odd not more developers were reporting a similar issue.

    Many thanks to Ken and Jamles who took the time to participate in this thread.

    • Marked as answer by CoolVotes Wednesday, August 19, 2015 7:52 PM
    Wednesday, August 19, 2015 7:51 PM

All replies

  • Are you trying to run this inside a virtual machine?
    Saturday, August 15, 2015 7:25 PM
  • I have Windows 10 OS.  I simply created a 'Hello World' using Visual Studio 2015.

    I do not run this inside any virtual machine. Any virtual machine related actions are instigated by the Visual Studio itself, when I press on 'Start' (F5) .

    This works on Local Machine.

    But when I choose an emulator, eg 'Mobile Emulator 10.0.10240.0 720p 5 inch 1GB',   I get the error message I posted above.

    Thank you.

    Sunday, August 16, 2015 3:10 AM
  • Hi CoolVotes,

    I would suggest you directly open your Hyper-V manager to create a virtual machine to see if you can directly create one without any error message like "failed to add device 'Virtual Hard Disk'".

    If you cannot create the virtual machine, probably something wrong with your Hyper-V, please further consult at hyper V forum: https://social.technet.microsoft.com/Forums/windowsserver/en-us/home?forum=winserverhyperv

    If you can create one manually, probably something wrong with your Visual Studio commands, basically I would suggest you remove the related virtual machines and repair your Visual Studio to see if it works again.

    Any virtual machine related actions are instigated by the Visual Studio itself, when I press on 'Start' (F5) .

    >>Basically Visual Studio also create the virtual machine on Hyper-V by some command lines.

    --James


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, August 19, 2015 6:38 AM
  • Problem solved !

    Solution uninstall Hyper-V (restart pc) and reinstall it (restart pc).   That's it.   All emulators in Visual Studio worked 100% after doing this today.    (Control Panel\Programs\Programs and Features\Turn Windows Features On or Off: Untick Hyper-V)

    I had done this process from the very first day I had this issue, and several times afterwards, but it did not yield any results during these previous attempts.    Today however it did the job.  Apparently a couple of days ago Microsoft released some new virtualization features for Windows 10, and probably in there was the solution to my problem.  Its a bit odd not more developers were reporting a similar issue.

    Many thanks to Ken and Jamles who took the time to participate in this thread.

    • Marked as answer by CoolVotes Wednesday, August 19, 2015 7:52 PM
    Wednesday, August 19, 2015 7:51 PM