none
Sending IDOC to SAP using WCF-SAP Adapter with NCO Option in BizTalk 2013 R2 RRS feed

  • Question

  • Hi,

    I have installed CU2 Update on BizTalk 2013 R2. When we are trying to send IDOC to SAP using WCF-SAP Connection using connector type- "nco"( .net connector type), the idoc has been posted to SAP.

    But in SAP, The IDOC is failing with below error. Kindly please let me know how to fix this issue.

    Status record: 60

    EDI: Syntax error in IDoc (segment cannot be identified)

    Message no. E0078

    Monday, July 18, 2016 9:10 AM

All replies

  • Hi,

    This is a SAP error message. Maybe you can try to post it in a SAP forum. By the way, CU2 is available for BizTalk 2013 R2 :)


    Best regards, Kjetil :) Please remember to click "Mark as Answer" on the post that helps you. This can be beneficial to other community members reading the thread.

    My blog

    Monday, July 18, 2016 7:38 PM
  • Hi Vinod,

    Welcome to BizTalk forum.

    As Kjetil Tonstad mentioned above, it seems that this is SAP issue, SAP forum is more suitable for you.

    I will move this thread to Off-topic forum, thanks for your understanding.

    Best regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, July 19, 2016 5:54 AM
  • Thanks for your reply.

    But the same IDOC is coming in proper format in SAP with no errors when i use classic RFC in BizTalk.

    Hence this is the reason that i believe it is still to be an issue with BizTalk NCO connector issue

    Tuesday, July 19, 2016 8:00 AM
  • Hi,

    WCF-SAP adapter support for the SAP .NET Connector (NCo) is added to BizTalk Adapter Pack, it's recommended to use this fix, the fix that resolves this issue is included in the following cumulative updates for BizTalk Server and BizTalk Adapter Pack: 

    if the issue still persists after all of them, you might try looking into a few more advanced alternatives.

    Regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Mauricio Feijo Monday, August 1, 2016 11:23 PM
    • Marked as answer by Angie Xu Monday, August 8, 2016 5:29 AM
    • Unmarked as answer by vinod959 Tuesday, August 9, 2016 2:11 PM
    Monday, July 25, 2016 6:36 AM
  • Hi Angie,

    Thanks for your reply. I installed CU2, CU4 updates of BizTalk 2013 R2.  But it is still same syntax issue for IDOC using NCO option. Has anyone used nco option to send idoc to sap in biztalk 2013 r2?

    Even we have escalated this case to product team in microsoft, am still waiting for the fix.

    Tuesday, August 9, 2016 2:13 PM