none
ADO Entity Data Model RRS feed

  • Question

  • I ran this problem in creating an .edmx file which is a ADO Entity Data Model.

    I have this table that has 2 columns which references keys from another column say...

    Table A has colA as primary key.

    Table C has colC as primary key.

    Then Table B has colA and colC as both primary key which references from the tables mentioned above.

    So while creating the model from the database in the wizard, I ticked the checkbox for tables A,B, and C. But the problem is table B is not showing in the model. I've tried to update the model from database but still the model is not showing. So now the problem is I cannot use the table B entity to add records to my database.

    Is this some kind of bug to an .edmx file?


    :)

    Monday, September 10, 2012 6:13 AM

Answers

All replies

  • Hi singkripiti;

    To your question, "Is this some kind of bug to an .edmx file?", no it is operating as designed. Please read this article on the subject it will explain on how to use it.

    Entity Framework: Queries involving many to many relationship tables

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    • Proposed as answer by Sygrien Monday, September 10, 2012 1:11 PM
    • Marked as answer by singkripiti Tuesday, September 11, 2012 7:54 AM
    Monday, September 10, 2012 12:50 PM
  • yeah i did that

    i created a another column which serves as another primary key to my many-to-many relationship table.


    :)

    Tuesday, September 11, 2012 7:55 AM