locked
Problem with Access database and ASP Page - IIS 7 and Windows Vista Ultimate RRS feed

  • Question

  • User2119820554 posted
    Hello,

    I've installed Windows Vista Ultimate with IIS 7 and common ASP pages are working fine ;-))

    Nevertheless as soon as I try to do a connection to an Access database (DSN or DSN less) I've got an error 500 page. The pages and connection was working on Windows XP.

    Do you have an idea to help me ?

    Florian
    Thursday, May 10, 2007 4:08 AM

Answers

All replies

  • User157784788 posted

    Check IIS log files - C:\inetpub\logs\LogFiles\W3SVC1

    You will find something like this:

    |3|800a0e7a|Provider_cannot_be_found._It_may_not_be_properly_installed
    or
    5|800a0ea9|Provider_is_not_specified_and_there_is_no_designated_default_provider

    You will need to install AccessDatabaseEngine for vista

    2007 Office System Driver: Data Connectivity Components http://www.microsoft.com/downloads/details.aspx?FamilyID=7554f536-8c28-4598-9b72-ef94e038c891&DisplayLang=en

    Download here

    HTH.

    ~ Ganesh

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, May 10, 2007 4:45 AM
  • User2119820554 posted
    I'm checking but before having conclusions I thank you for your quick answer and for your precious help!
    Thursday, May 10, 2007 5:10 AM
  • User2119820554 posted
    Hello again Ganesh,

    I'v checked and it's not working. My Access files are Access 2000 or 2003.
    How can I have more info about the error. I only have error 500 standard message but it could be easier to debug with an extensive error message.

    Any idea?

    Florian
    Thursday, May 10, 2007 9:40 AM
  • User2119820554 posted
    Hello again,

    I've checked in my IIS log and I've got this error message :

    #Software: Microsoft Internet Information Services 7.0
    #Version: 1.0
    #Date: 2007-05-10 19:22:17
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-05-10 19:22:17 127.0.0.1 GET /test/index.asp |8|80004005|[Microsoft][Pilote_ODBC_Microsoft_Access]_Network_drive_or_hard_drive_error. 80 - 127.0.0.1 Opera/9.20+(Windows+NT+6.0;+U;+fr) 500 0 0
    2007-05-10 19:22:17 127.0.0.1 GET /favicon.ico - 80 - 127.0.0.1 Opera/9.20+(Windows+NT+6.0;+U;+fr) 404 0 2

    Any idea
    Thursday, May 10, 2007 4:53 PM
  • User-848894299 posted

    Hi,

    To enable ASP error message, please see http://forums.iis.net/thread/1652934.aspx

    Regarding the Access/ASP issue, please see   http://support.microsoft.com/kb/926939

    Ray

     

     

    Thursday, May 10, 2007 5:31 PM
  • User1832207001 posted

    I've got the same error, i tried creator control and changing permission but nothing is working.. what would be the problem?? ASP is working but i'm not able to connect database. It Give 500 error or loads the page, and i get an error contact the administrator.. What to do??


     

    Friday, January 4, 2008 8:55 PM
  • User989702501 posted

    Post the exact error msgs here..  and what user do you grant the permissions ? is it the app user ?

    Sunday, January 6, 2008 10:56 PM
  • User1783730947 posted
    Microsoft OLE DB Provider for ODBC Drivers error '80004005' [Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data.
    Monday, February 4, 2008 11:10 AM
  • User1076070881 posted

    I´m having exactly the same problem. I´ve already granted full permission for user "IUSR" and "Everyone" on the application and database folders, but the error stands. Is there already any ServicePack for Vista that solves this?

    I don´t know what else to do, I´ve already browsed the whole web for this solution! I wouldn´t like to uninstall Vista just because of this error.

    Thanks!

    Friday, March 28, 2008 2:43 PM
  • User1832207001 posted

    This appcmd command will turn off loadUserProfile for the Default Application Pool.  if your application runs in a different AppPool, make the corresponding change:

    %windir%\system32\inetsrv\appcmd set config /section:applicationPools /[name='DefaultAppPool'].processModel.loadUserProfile:false


    That did the job... Check out Bills blog
    http://blogs.iis.net/bills/archive/2007/05/21/tips-for-classic-asp-developers-on-iis7.aspx

    It should be run as administrator... first i just run the command in cmd.. then read it should be run as administrator.. right click cmd and "Run as Administrator" and then type the command. This should fix.

    Friday, March 28, 2008 4:19 PM
  • User1076070881 posted

    Thanks for the attention, but it also didn´t work. I was running only the cmd (not right-clicking cmd and "Run as Administrator"), but my user is the administrator of the machine. Even though, I did what you told, and it didn´t work too.

     Any other tips?? I had already read Bill´s Blog, but any of the solutions worked. Is that a bug in my machine?
     

    Saturday, March 29, 2008 11:58 AM
  • User1611831498 posted

    Definetly there is a solution

    We all would have encountered the same problem, when upgrading from xp to vista, for passionate developers of ASP AND

    DATABASES.

    Understanding the scenario.

     After using XP for 7 years and upgrading to VISTA ULTIMATE AND IIS 7 I tried to run my asp projects by creating virtual

    directories. The physical path to my asp files would be in different drive than the C:\inetpub\wwwroot\... coz it is easier

    for me to keep my data safe.

    Then running the site http:\\localhost\myproject1 in IE7. mY ASP pages did not work and i got the error

    "An error occurred on the server when processing the URL. Please contact the system administrator."

    After the changing the send error to browser property to TRUE in the IIS 7 manager I got the error

    Microsoft JET Database Engine error '80004005'
    Unspecified error


    since i was trying to make a database connection.

    I spend nearly 24 hrs searching solution in various forums and blogs. Microsoft has clearly stated in their article how to rectify this problem in the following link.

    http://support.microsoft.com/kb/926939

    According to the article I change the permissions to the temporary directory by entering the following commands in the CMD while running as administrator.

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant Users:(CI)(S,WD,AD,X)

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER":(OI)(CI)(IO)(F)

    But i did not follow the workaround solution as it may compromise the security.And again running the site it did not work.Then i followed the workaround solution compromising the security

    Entering the following commands in the CMD by running as administrator

    %windir%\system32\inetsrv\appcmd set config /section:applicationPools /

    [name='DefaultAppPool'].processModel.loadUserProfile:false

    Now my site works great, compromising security. I thing we are classic asp programmers not IIS managers. We could write a strong code but it is for microsoft to bring a better solution.

    IIS 7 has been made with tons of features, I would appreciate if there is a easy way working on with IIS 7 than entering all the commands in CMD to run you ASP'S.

    Monday, April 28, 2008 8:40 AM
  • User1076070881 posted

    Hi all.

    I had already tried this one too, but it didn´t work neither. My problem was even worse: I didn´t upgrade from XP to Vista, my laptop came with Vista Home Premium pre-installed.

    Even though, I finally could get it resolved: after trying all of the above, the only thing that worked was to set the default user of IIS Anonymous Acces to my own user. That is, instead of using "IIS_IUSR", I´m using my own (administrator of the machine) user over IIS.

    That was problably because the machine used my user to open the Database file, so when IIS tried to reach it, it was "already open to another user". That´s the only thing I could figure out...

    Thanks to all! now it´s working.

    PS: I´m running the application on wwwroot because I couldn´t make it run on a different folder. And still don´t know why, just know that that´s the way it is...

    Monday, April 28, 2008 2:10 PM
  • User1435573684 posted

    Hello Friend!

    This is siva. I also have the same problem. If you got any idea, please help me...

    you give reply in this mail id: sivabas2007@yahoo.co.in.

    Advance thanks,

    Siva 

     

    Saturday, July 12, 2008 11:40 AM
  • User-1656722207 posted

    Hey all,

    I had the exact problem. My laptop came with Vista Home Premium and I had been getting this error for the longest time. After a lot of research on the net and trying various solutions, I finally resolved this issue.

    I had to set the user persmission of IUSR and IIS_IUSRS to allow read/write to the 'TEMP' (if you dont know, type echo %TEMP% in cmd) directory and the 'inetpub' directory. It seems to have solved this problem. Before I could not access the DB using OLE DB or MS Access drivers. Now I can access it using both.

    Hope that helps.

    Sunday, September 13, 2009 4:35 PM