locked
Error deploying asp.net app from GitHub to Azure RRS feed

  • Question

  • User764588242 posted

    When I deploy direct to Azure from Visual Studio 2017, my app runs fine.  But I need to deploy from GitHub.  When I do, it fails and the activity log shows the same error for most of the references:

    All packages listed in packages.config are already installed. D:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.Common.CurrentVersion.targets(1819,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly...

    I've deployed many apps to Azure from GitHub before and never had any issue.  I assume it may be related to the deployment of the packages.  What is weird is some of my colleagues did the exact same steps as I did and their apps deploy fine.  I tried the template VS gitignore thinking maybe it would not push my packages and Azure would use NuGet but that hasn't solved the problem.  Advice is appreciated.

    Wednesday, September 13, 2017 7:30 PM

All replies

  • User-271186128 posted

    Hi gcstudent1,

    You could try to re-upload web app files to the GitHub and re-deploy the web app from GitHub to Azure.

    Best regards,
    Dillion

    Thursday, September 14, 2017 5:46 AM
  • User764588242 posted

    Thanks for the reply.  I've tried this, even to a new repository with no luck.

    I did fix it this way:

    It seems without FIRST having the vs boilerplate .gitignore, the git commits include the packages folder and this causes all sorts of problems when deploying to Azure.  Publishing straight from VS to Azure does avoid this, but then it removes the benefits of using GitHub and continuous deployment.

    Thursday, September 14, 2017 2:12 PM