none
no code editor theme for C#

    Question

  • Hello,

    There are no colors in the code editor for C# files for Visual Studio 2015.

    How do I correct this?

    This only occurs for C# files.

    Thanks.


    williamj

    Friday, November 27, 2015 5:05 PM

Answers

  • Hi williamj8,

    When does this problem occur? After installing or using for a while?

    If using for a while, please try reset all settings through menu Tools -> Import and Export settings -> Reset all settings.

    If after installing, do you get any error or warning message when installing? Please try repair you Visual Studio with steps of Control Panel -> Programs -> Visual Studio -> Change -> Repair.

    Please check the default editor for your C# code. Right-click the C# file, choose Open with..., which will open a window to let you choose the editor for you C# file. Please make sure that your default editor for C# code is "CSharp Editor (Default)".

    In addition, please run your Visual Studio 2015 with "Devenv.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution. Please also close all third part software when running Visual Studio, such as antivirus software.

    Best Regards,
    Weiwei

    Monday, November 30, 2015 6:45 AM
    Moderator

All replies

  • Hi williamj8,

    When does this problem occur? After installing or using for a while?

    If using for a while, please try reset all settings through menu Tools -> Import and Export settings -> Reset all settings.

    If after installing, do you get any error or warning message when installing? Please try repair you Visual Studio with steps of Control Panel -> Programs -> Visual Studio -> Change -> Repair.

    Please check the default editor for your C# code. Right-click the C# file, choose Open with..., which will open a window to let you choose the editor for you C# file. Please make sure that your default editor for C# code is "CSharp Editor (Default)".

    In addition, please run your Visual Studio 2015 with "Devenv.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution. Please also close all third part software when running Visual Studio, such as antivirus software.

    Best Regards,
    Weiwei

    Monday, November 30, 2015 6:45 AM
    Moderator
  • Hello,

    The issue was resolved by performing a clean install.

    Thanks.


    williamj

    Thursday, December 3, 2015 3:04 PM