locked
Blue tooth blocks serial communcation RRS feed

  • Question

  • Hello all,

    I have enabled all the Bluetooth features in BSP, as the result of that I could not communicate with the device connected to Com1.  I would like to know if there is any way to resolve that.

    Thank you

    Monday, June 3, 2013 5:09 PM

Answers

  • Hi,

    Maybe your bluetooth driver uses serial port 1 for communication. Check Bluetooth registry settings 

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\Transports\BuiltIn\ ] and other keys to figure out which com port is being used by Blueotooth , and if possible use some other com port for BT communication.

    Regards,

    Balaji.

    • Proposed as answer by Bruce Eitman Wednesday, June 5, 2013 2:54 PM
    • Marked as answer by Liang1 Wednesday, June 5, 2013 7:52 PM
    Tuesday, June 4, 2013 3:51 AM
  • Override the registry setting for BT HCI which might be accessing the COM 1

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\Transports\BuiltIn\1]
         "name"="COM1:"

    Change it some other com port which should be interfaced with BT.

    --- Misbah    


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    • Proposed as answer by Bruce Eitman Wednesday, June 5, 2013 2:54 PM
    • Marked as answer by Liang1 Wednesday, June 5, 2013 7:52 PM
    Tuesday, June 4, 2013 12:35 PM

All replies

  • Hi,

    Maybe your bluetooth driver uses serial port 1 for communication. Check Bluetooth registry settings 

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\Transports\BuiltIn\ ] and other keys to figure out which com port is being used by Blueotooth , and if possible use some other com port for BT communication.

    Regards,

    Balaji.

    • Proposed as answer by Bruce Eitman Wednesday, June 5, 2013 2:54 PM
    • Marked as answer by Liang1 Wednesday, June 5, 2013 7:52 PM
    Tuesday, June 4, 2013 3:51 AM
  • Override the registry setting for BT HCI which might be accessing the COM 1

    [HKEY_LOCAL_MACHINE\Software\Microsoft\Bluetooth\Transports\BuiltIn\1]
         "name"="COM1:"

    Change it some other com port which should be interfaced with BT.

    --- Misbah    


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    • Proposed as answer by Bruce Eitman Wednesday, June 5, 2013 2:54 PM
    • Marked as answer by Liang1 Wednesday, June 5, 2013 7:52 PM
    Tuesday, June 4, 2013 12:35 PM
  • Thank you very much for your help!
    Wednesday, June 5, 2013 7:53 PM