locked
Power Pivot : Data Model not getting refreshed when new rows added in the Excel Sheet RRS feed

  • Question

  • Hello,

    I have created the Power Pivot Chart from the data in the Excel Sheet of the same Excel file.

    When I am adding new Rows to the Excel sheet data, it is not getting updated in the Data Model.

    I tried Update, Update All on Data tab.

    Also I tried Refresh, Refresh all on Manage > Data Model window. When I do refresh all, it shows the all the pivot tables in the data model are getting refreshed but the same no of rows. Not adding up the new ones.

    How can I refresh my datamodel in this case now ?

    Please suggest.

    Thank you,

    Mittal.

    Wednesday, September 10, 2014 4:23 AM

Answers

  • I think you should follow steps:

    1- check if rows are added to link table. Example:

    Table 1.
    COUNTRY
    CROATIA
    CZECH REPUBLIC
    HUNGARY
    POLAND
    ROMANIA
    SLOVAKIA (SLOVAK REPUBLIC)
    USA row not added to linked table
    GERMANY row not added to linked table
    Table.2
    COUNTRY
    CROATIA
    CZECH REPUBLIC
    HUNGARY
    POLAND
    ROMANIA
    SLOVAKIA (SLOVAK REPUBLIC)
    USA row added to link table
    GERMANY row added to link table

    2- if rows are added refresh data in model. Click refresh from PP menu. If not, drag bottom right corner of the data table to expand selection  on new rows

     3. Refresh pivot table as a data for your chart

    Gordonik

    • Proposed as answer by Charlie Liao Sunday, September 21, 2014 6:32 AM
    • Marked as answer by Charlie Liao Tuesday, September 23, 2014 2:50 AM
    Thursday, September 18, 2014 1:43 PM

All replies

  • Hey Mittal,

    if you click "Refresh" or "Refresh All" in Data-tab in Excel you only refresh Excel's Pivot-tables, but not your DataModel which is in PowerPivot. If you want to refresh this on, click the "Manage"-button on the "PowerPivot"-tab, go to your table and then there should be a tab called "Linked Table".

    You have plenty of options how the PowerPivot-Model should refresh the data coming from the Excel-sheets.

    Have a look at the attached screenshot, this should make it clear

    Kind regards,

    Matthaeus

    ______________________________________

    Please mark helpful posts and answers! :)

    Wednesday, September 10, 2014 1:52 PM
  • Matthaeus, Refresh from Excel's Data menu will refresh the Power Pivot data model as of Excel 2013. The limitation you have described is only for Excel 2010.

    Mittal, when you add rows to the data in Excel, is that data appearing in your linked table in the Power Pivot window?

    Wednesday, September 10, 2014 6:21 PM
  • Thank you for your responses.

    @Matthaeus and @Greg, When I open my Excel 2013 sheet and clicked on Manage and on the Data Model window I do not even see this Table Tools Tab.

    I tried to search this tab in File > Options > Ribbon Toolbar. But could not find any way to add it to the menu.

    How can I get this Tab in Excel 2013 if it is not visible at  all ?

    Any idea?

    Thank you,

    Mittal.

    Thursday, September 11, 2014 8:36 AM
  • Have you added the table to the Power Pivot model as a linked table?

    Instructions here

    Thursday, September 11, 2014 1:55 PM
  • I think you should follow steps:

    1- check if rows are added to link table. Example:

    Table 1.
    COUNTRY
    CROATIA
    CZECH REPUBLIC
    HUNGARY
    POLAND
    ROMANIA
    SLOVAKIA (SLOVAK REPUBLIC)
    USA row not added to linked table
    GERMANY row not added to linked table
    Table.2
    COUNTRY
    CROATIA
    CZECH REPUBLIC
    HUNGARY
    POLAND
    ROMANIA
    SLOVAKIA (SLOVAK REPUBLIC)
    USA row added to link table
    GERMANY row added to link table

    2- if rows are added refresh data in model. Click refresh from PP menu. If not, drag bottom right corner of the data table to expand selection  on new rows

     3. Refresh pivot table as a data for your chart

    Gordonik

    • Proposed as answer by Charlie Liao Sunday, September 21, 2014 6:32 AM
    • Marked as answer by Charlie Liao Tuesday, September 23, 2014 2:50 AM
    Thursday, September 18, 2014 1:43 PM