locked
Visual Studio Macros too slow RRS feed

  • Question

  • Hi,

    I works with XP/Studio 2005/C++, I can't record macros, this process is too slow, takes a centures just to add 5-10 characters.

    I installed service pack 1, it doesn't help.

    Best regards,

    Vladimir

    Sunday, October 24, 2010 9:44 AM

Answers

  • Hi Valadimir,

     

    Thanks for your post.

    One of the biggest culprits for Visual Studio 2005 slowness is Intellisense. What I frequently experience is that Intellisense is working nearly non-stop to "re-index" symbols (or whatever you call it). There are some workarounds might help you:

    Could you please check out this link to get a better understanding of Intellisense:

    Intellisense Info

    Then please check out this link for some macros that I've had a lot of success with:

    Intellisense Macros

    With those macros, you can turn off intellisense (without renaming any DLLs), restart it, delete the ncb file (which you can do manually, but this is a convenience) and it can give you the status of Intellisense.

    Hope this can help.

     Best Regards,

    Ziwei Chen

     

     

    • Marked as answer by Victor_Chen Friday, October 29, 2010 9:06 AM
    Tuesday, October 26, 2010 5:38 AM