locked
After deleting an old parameter, and added a new parameter in report builder 3.0, a wrong message comes up RRS feed

  • Question

  • Here is the error message: the filter value expression for the tablix2 refers to a non-existing report parameter xx. 

    I did delete the old parameter from every dataset from the design view. I don't know how to find the tablix2 codes as shown in other posts.

    In the design view, the view ribbon in the top only shows grouping, ruler, etc. I don't know click where to view the codes. 

    Thanks for the help. 

    Thursday, September 21, 2017 7:18 PM

All replies

  • Hi sunshinevision,


    According to your error information, it seems that you set the filter on Tablix2 which might refer to the old parameter values. If so , you could check the Tablix2’s properties(right click the Tanlix to choose Tablix properties->filter) or you could delete the Tablix 2 to see whether it work or not. And you also need to check the items(dataset, Tablix) which you refer to old parameter whether it has referred to new parameter


    In addition, you said you want to find the Tablix 2, right? If so, you could find it in properties window like below

    If you have any question, please feel free to ask.
    Best regards,
    Zoe Zhi


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, September 22, 2017 2:41 AM