locked
getOrders at Sandbox results in -400042 : ERROR_API_FAILED_DUE_TO_APPLICATION_ERROR RRS feed

  • Question

  • I try to download a complete account from the sandbox, but the getOrders results in -400042. Does anyone has a clue where this error comes from?
     
    Here is my soap request :
     
     <?xml version="1.0" encoding="UTF-8" ?>
    - <soapenv:Envelope xmlns: soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <soapenv:Header>
    - <ns1:ApiUserAuthHeader soapenv:actor="http://schemas.xmlsoap.org/soap/actor/next" soapenv:mustUnderstand="0" xmlns: ns1="http://adcenter.microsoft.com/syncapis">
      <ns1:UserName>*****</ns1:UserName>
      <ns1: Password>*****</ns1: Password>
      <ns1:UserAccessKey>*****</ns1:UserAccessKey>
      </ns1:ApiUserAuthHeader>
      </soapenv:Header>
    - <soapenv:Body>
    - <GetOrders xmlns="http://adcenter.microsoft.com/syncapis">
      <APIFlags>0</APIFlags>
      <CampaignId>34677</CampaignId>
      </GetOrders>
      </soapenv:Body>
      </soapenv:Envelope>
     
    result:
     
    <?xml version="1.0" encoding="utf-8" ?>
    - <soap:Envelope xmlns: soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    - <soap:Body>
    - <soap:Fault>
      <faultcode>soap: Server</faultcode>
      <faultstring>Server was unable to process request. ---> |-400042|-1|ERROR_API_FAILED_DUE_TO_APPLICATION_ERROR|</faultstring>
      <detail />
      </soap:Fault>
      </soap:Body>
      </soap:Envelope>
    Thursday, June 28, 2007 1:58 PM

Answers

  • I will ask your Search Media Strategist to contact you and make sure you are listed properly.

    Jeff Dillon, Microsoft adCenter API Technical Support
    Friday, June 29, 2007 8:42 PM
  • You appear to be correct. I was able to reproduce here, and we are working to address this issue. I'm guessing it's going to be a few days though. I also created another username to test the same account, and got the same error. I haven't tried it yet, but you might be able to create and manage brand new campaigns successfully in the Sandbox.

    Jeff Dillon, Microsoft adCenter API Technical Support
    Thursday, July 5, 2007 9:31 PM

All replies

  • Hi,

    We are preparing to upgrade Sandbox today, as described here. We are addressing this issue in the upgrade.

    http://adcenterdev.spaces.live.com/

    You should have received a notification email?

    Please try again on Monday.

    Jeff Dillon, Microsoft adCenter API Technical Support

    Thursday, June 28, 2007 2:45 PM
  • Didn't receive a notification mail at all. Where can i subscribe myself to the mailinglist ???
    Friday, June 29, 2007 11:22 AM
  • I will ask your Search Media Strategist to contact you and make sure you are listed properly.

    Jeff Dillon, Microsoft adCenter API Technical Support
    Friday, June 29, 2007 8:42 PM
  • I'm still getting this error at the same location.

     

    Are you still sure it's "just" a maintanance problem ??

    Wednesday, July 4, 2007 2:24 PM
  • You appear to be correct. I was able to reproduce here, and we are working to address this issue. I'm guessing it's going to be a few days though. I also created another username to test the same account, and got the same error. I haven't tried it yet, but you might be able to create and manage brand new campaigns successfully in the Sandbox.

    Jeff Dillon, Microsoft adCenter API Technical Support
    Thursday, July 5, 2007 9:31 PM