locked
VS2013 - Closing Windows Store App Does Not End Debug Session

    Question

  • It seems to me something has changed with recent VS/OS updates in the last few days and I don't know if it is just my environment or a broader issue. I would appreciate if someone can help confirm...

    Simple steps to test what I'm seeing:

    1. Create a blank or other simple C# Windows Store application.

    2. Launch debug session (F5) for the app on local or remote machine. 

    3. After it starts up, close app by dragging to bottom of screen or clicking upper right "X.

    Expected behavior:

    The debug session would end and VS would be back in coding mode.

    What I'm Seeing:

    The app's window closes but the debug session does not end. Checking Task Manager reveals that the app continues in a "Running" state indefinitely. I have to manually end the debugging session (Shift+F5) to get things to stop.

    I have tried an uninstall/reinstall of VS2013, and also tried a clean install of VS with latest updates on another machine. Same behavior.

    Anyone else having this issue?

    Friday, October 31, 2014 2:46 PM

Answers

All replies

  • Don't worry, this is a normal phenomenon.

    see these blogs:

    Swipe-Down-to-Kill Changes in Windows 8.1 Store apps

    [Guide] How to Close Metro Apps Permanently in Windows 8.1?


    在現實生活中,你和誰在一起的確很重要,甚至能改變你的成長軌跡,決定你的人生成敗。 和什麼樣的人在一起,就會有什麼樣的人生。 和勤奮的人在一起,你不會懶惰; 和積極的人在一起,你不會消沈; 與智者同行,你會不同凡響; 與高人為伍,你能登上巔峰。


    • Edited by Bill ChungMVP Friday, October 31, 2014 4:06 PM
    • Marked as answer by ilevitt Saturday, November 1, 2014 3:19 PM
    Friday, October 31, 2014 4:05 PM
  • I knew this was the behavior for deployed apps in 8.1 but had myself convinced things ran differently in the VS IDE--I guess flipping between multiple environments had me confused. Thank you for clearing up!
    Saturday, November 1, 2014 3:22 PM