locked
Cannot see DataGridView Completelly RRS feed

  • Question

  • Hello,

    I have a DataGridView with a lot of columns that is inside a window form.

    The problem is that the scroll bar is not proportional to the number of columns and I cannot see the last columns, if I resize the first columns to some short width then I do see the rest of the columns that I was not able to see.

    Question:

    Am I missing some kind of property to show the complete DGW with all columns?

    I have already tried with different autosize options for columns but nothing works.

    Thanks,

     


    Kikeman Electric Systems Engineer
    • Edited by Kikeman Wednesday, December 21, 2011 1:00 AM
    Wednesday, December 21, 2011 12:58 AM

Answers

  • Hello Kikeman

    If you want use autosize options for columns for datagridview

    1. Open DataGridView Property window

    2. Choose Layout from Propertis window

    3. Get AutoSizeColumnsMode from Layout

    4. Choose AllCells for AutoSizeColumnsMode

    5. Exactly You want choose AllCells for AutoSizeRowsMode


    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    • Marked as answer by Kikeman Wednesday, December 21, 2011 4:39 PM
    Wednesday, December 21, 2011 5:44 AM

All replies

  • if u are using simple gridview without any datalist. Then you can using the pagging property.
    Wednesday, December 21, 2011 3:59 AM
  • Hello Kikeman

    If you want use autosize options for columns for datagridview

    1. Open DataGridView Property window

    2. Choose Layout from Propertis window

    3. Get AutoSizeColumnsMode from Layout

    4. Choose AllCells for AutoSizeColumnsMode

    5. Exactly You want choose AllCells for AutoSizeRowsMode


    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    • Marked as answer by Kikeman Wednesday, December 21, 2011 4:39 PM
    Wednesday, December 21, 2011 5:44 AM
  • Ok, thanks guys, I found the error, I used as Sankarsan said "AllCells", I was changing somewhere else to Fill, now it works, thanks

    • Edited by Kikeman Wednesday, December 21, 2011 4:39 PM
    Wednesday, December 21, 2011 4:18 PM