locked
Static IP on Ethernet connection RRS feed

  • Question

  • Hi,

    I have two RP3's that I am trying to use on a LAN that does not have a DHCP server.  I wanted to use NETSH to set the Ethernet interface to a static IP.  I was using Powershell through the Wifi connection to do this.  I used the following command:

    netsh interface ip set address "Local Area Connection* 1" static 192.168.1.212 255.255.255.0 68.105.28.16

    After using the command with no error...I turned off the Wifi and then plugged in. 

    Once I plugged in, the hardwired address some random address that was not in the range of my subnet.  What am I missing?

    Build is 10.0.15051.0

    Also, is there a way to prevent the OS from trying to set time using timeservers on bootup?  I need to give a lan demo of my devices and it's not working out.

    Thank you


    Dan DeMerchant

    Monday, March 27, 2017 10:41 PM

Answers

  • hello

    [pi3]: PS C:\> netsh interface show interface
    
    Admin State    State          Type             Interface Name
    -------------------------------------------------------------------------
    Enabled        Disconnected   Dedicated        Ethernet
    Enabled        Connected      Dedicated        Wi-Fi

    have you tried to use Ethernet instead of Local...

    Also, is there a way to prevent the OS from trying to set time using timeservers on bootup?

    disable the Windows Time service w32time should help

    Set-Service w32time -StartupType Disabled

    br
    Andre

    Monday, March 27, 2017 11:22 PM