locked
Website Templates RRS feed

  • Question

  • User1999497519 posted

    I just deleted the old version of "Visual Studio Express for Web" and downloaded the new version of "Visual Studio Express for Web 2013".

    I opened up the new "Visual Studeo Epress for Web 2013" and on the "Start Page" I click on "New Web Site...". Under Installed>Templates>Visual Basic I have only 3 templates installed

    ASP.NET Web Site (Razor v2)

    ASP.NET Web Site (Razor v3)

    WCF Service

    My question is shouldn't I have more templates then just these 3 that are not all that important to me?

    Thanks!

    Sunday, December 15, 2013 6:48 PM

Answers

  • User-166373564 posted

    Hi Steve Mracek

    I open Visual Studio 2013 on my side, there are installed Web Site templates in New Web Site below:

    • ASP.NET Empty Web Site
    • ASP.NET Web Forms Site
    • ASP.NET Web Site(Razor v2)
    • ASP.NET Web Site(Razor v3)
    • ASP.NET Dynamic Data Entities Web Site
    • WCF Service
    • ASP.NET Reports Web Site

    For this issue, In addition to the installed templates in the New Project and Add New Item dialog boxes, you can author your own templates or download and use templates created by the community.

    At the same time you could also try repair your Visual Studio on your side, and check whether it helps.

    Best regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 1:51 AM
  • User71929859 posted

    I just deleted the old version of "Visual Studio Express for Web"

    You shouldn't have just deleted it. The proper way to remove is by uninstalling the program from "Program and Features" in Control Panel. There are keys in the registry and there are more than one place (In windows folder etc.) where the files related to visual studio product resides.

    My question is shouldn't I have more templates then just these 3 that are not all that important to me?

    Try this solution

    http://chiragrdarji.wordpress.com/2008/05/06/missing-templates-in-visual-studio-installed-templates/

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 5:01 PM
  • User281315223 posted

    As the others have mentioned, you might want to try either manually repairing your installation of Visual Studio 2013 or attempt to manually install the appropriate templates through the Visual Studio command prompt (ensure that you are running as an Administrator if you elect to use this option).

    I would also recommend checking that you have all of the available updates for your new version of Visual Studio and that you are targeting the appropriate environment and framework version (as these will determine which templates are available).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 5:18 PM

All replies

  • User-166373564 posted

    Hi Steve Mracek

    I open Visual Studio 2013 on my side, there are installed Web Site templates in New Web Site below:

    • ASP.NET Empty Web Site
    • ASP.NET Web Forms Site
    • ASP.NET Web Site(Razor v2)
    • ASP.NET Web Site(Razor v3)
    • ASP.NET Dynamic Data Entities Web Site
    • WCF Service
    • ASP.NET Reports Web Site

    For this issue, In addition to the installed templates in the New Project and Add New Item dialog boxes, you can author your own templates or download and use templates created by the community.

    At the same time you could also try repair your Visual Studio on your side, and check whether it helps.

    Best regards

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 1:51 AM
  • User71929859 posted

    I just deleted the old version of "Visual Studio Express for Web"

    You shouldn't have just deleted it. The proper way to remove is by uninstalling the program from "Program and Features" in Control Panel. There are keys in the registry and there are more than one place (In windows folder etc.) where the files related to visual studio product resides.

    My question is shouldn't I have more templates then just these 3 that are not all that important to me?

    Try this solution

    http://chiragrdarji.wordpress.com/2008/05/06/missing-templates-in-visual-studio-installed-templates/

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 5:01 PM
  • User281315223 posted

    As the others have mentioned, you might want to try either manually repairing your installation of Visual Studio 2013 or attempt to manually install the appropriate templates through the Visual Studio command prompt (ensure that you are running as an Administrator if you elect to use this option).

    I would also recommend checking that you have all of the available updates for your new version of Visual Studio and that you are targeting the appropriate environment and framework version (as these will determine which templates are available).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, December 23, 2013 5:18 PM