none
.NET Framework 2.0 Installation crashing "Regsvcs.exe" /bootstrap? RRS feed

  • Question

  • I've been trying to install .NET Framework 2.0 on one of our workstations and have been receiving a crash ("would you like to send this error report" type) whenever I do an install / repair / update to SP1 on .NET framework.

    After I confirm the "crash", the installer somehow still manages to finish with a "...has installed succesfully" message.  However, the internal applications we develop in .NET 2.0 refuse to run.

    Here are the various things I've tried:
    1. disable the distributed transaction coordinator service
    2. disabled all non-windows services
    3. turned off DEP (AlwaysOff)
    4. Setting language locale to English for both unicode and non-unicode applications for all users
    5. Used the .NET Framework clean up tool to completely clean off all traces of .NET Frameworks, restarted the computer, and tried the install from scratch.
    6. Tried installing .NET Framework 3.0 with a similar error, this time happening in "servicemodelreg.exe" with a "fileloadexception"

    I'm stumped.  This is a Windows XP 32-bit SP2 installation which I'd much rather not have to re-install from scratch.

    Any information on this mysterious crash beyond the methods I've tried above would be greatly appreciated.

    Thanks.
    Wednesday, November 21, 2007 2:03 AM

Answers

  •  

    Installation in Diagnostic mode:

     

    1)      Go to Start-> Run and type msconfig and press enter.

    2)      In the window that appears, under the Startup Type, please select Diagnostic mode

    3)      Then go to the Services tab and select the following services that are required for installation/repair in Diagnostic startup which are not selected by default

    a)      Plug and Play

    b)      System Restore Services

    c)      Windows Installer

    4)      Now press the apply button and then ok. This will ask you to re-start the machine, hit re-start.

    5)      Once you re-start the machine in Windows Diagnostic mode, re-try the installation and see if it helps.

     

     

    If the Diagnostic mode installation does not help

    Enable the installation logging using the msidebug.reg file from here http://astebner.sts.winisp.net/Tools/Forms/AllItems.aspx

     

    Try the installation logging and look into the log file using the steps mentioned here

    http://blogs.msdn.com/srib/archive/2007/10/30/general-installation-issues-net-visual-studio-tfs-service-packs.aspx 

     

    You would get more info from the log regarding the failure and with the error you can do search..

     

    If nothing helps, you can post the text from the verbose log file  around the text "value 3"

     

    Hope this helps

     

    Wednesday, November 21, 2007 2:03 PM