none
Howto disable automatic translation into german? RRS feed

  • Question


  • Most of the MSDN articles that I browse are spoiled by being automatically translated into German. That translation is horrible and I very much would like to know how I can switch that kind of unnecessary service off.

    Cheers,
    Ron.
    Monday, October 8, 2007 2:27 PM

Answers

  • Check your Internet browser settings -- your languages and region may be set to German; change them to English to view English content.

     

    Monday, October 8, 2007 4:51 PM

All replies

  • Hi Ron,

    there is no "automatic translation" on MSDN. Could you please describe exactly what your experience is and possibly post a link to a page that is getting automatically translated for you?

     

    Thanks

    Andrea Orimoto - MSFT

    Monday, October 8, 2007 4:42 PM
  • Check your Internet browser settings -- your languages and region may be set to German; change them to English to view English content.

     

    Monday, October 8, 2007 4:51 PM
  • Mine are Polish and I want them to stay that way. I want only to disable automatic translation on MSDN pages. You are not trying to tell me, that this feature is forced on, don't you?
    Thursday, November 21, 2013 12:07 PM
  • This thread is from 6 years ago Wojciech.  Likely the culprit here is your browser.  MSDN doesn't have built-in translation as a service.  You can also check what language region you're visiting.  Look for the two-letter combo in the URL.  'en-us' or try visiting here: http://msdn.microsoft.com/en-US/SelectLocale

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Friday, November 22, 2013 4:28 PM
  • Same question from my side;

    on a MSDN page  ("support.microsoft.com/kb/141571/de") I get the german comment  "Hinweis: dies ist ein maschinell übersetzter Artikel"  ("this is automatically translated") with following text in horrible german lke

    "In Microsoft Excel können die On Error-Anweisung eine Microsoft Visual Basic for Applications-Makro (Subprozedur) Sie Auffangen von Fehlern und umleiten, die Anweisungen für die Fehlerbehandlung in einer Prozedur. Mit Fehlerbehandlung, erleichtern Sie Ihre Makros und Ihrer Anwendung verwenden, indem Sie Laufzeitfehler abfangen, bevor die Benutzer sehen. "

    I would really like to read the original article without any machine made translation.

    Wednesday, December 11, 2013 1:22 PM
  • I have the same problem but I get everything in Swedish. No way to turn off but i can easily change the translation to a vast number of other languages that I don't speak. Very useful feature.....

    Please add a option to turn this crap off without changing my browser settings or messing with profiles and such. To make matters worse it also translates some commands. "!analyze -visa" just won't work (should be "!analyze -show", show = visa in swedish).

    The generated translations into Swedish are very hilarious to read and i recomend that you submit a number of them to damnyouautocorrect, but please remove them from the support section so I can get on with my work..

    Friday, December 13, 2013 11:39 AM
  • Hey Microsoft! This is ridiculous! Turn this auto-translate off, or even better: kill it with fire!.

    If we didn't know how to read English we wouldn't be working in IT. I don't want to change the language settings in my browser. Stop forcefeeding your users this useless crap.

    Friday, December 13, 2013 2:24 PM
  • yes there is:

    https://login.live.com/login.srf?wa=wsignin1.0&rpsnv=12&checkda=1&ct=1392559791&rver=6.2.6289.0&wp=LBI&wreply=http:%2F%2Fsupport.microsoft.com%2FMSAccount%2FSignIn%2FSignIn.aspx%3FRedirectionTo%3D%252fkb%252f329308&lc=1043&id=288908

    Sunday, February 16, 2014 2:11 PM
  • It has and it is annoying.

    I want to read a human translated version or an english version if no human translation exist

    https://login.live.com/login.srf?wa=wsignin1.0&rpsnv=12&checkda=1&ct=1392559791&rver=6.2.6289.0&wp=LBI&wreply=http:%2F%2Fsupport.microsoft.com%2FMSAccount%2FSignIn%2FSignIn.aspx%3FRedirectionTo%3D%252fkb%252f329308&lc=1043&id=288908

    Sunday, February 16, 2014 2:12 PM
  • there are browser extensions to replace text in urls.

    For example: https://chrome.google.com/webstore/detail/switcheroo-redirector/cnmciclhnghalnpfhhleggldniplelbg/related

    I use it to replace msdn.microsoft.com/es-es by msdn.microsoft.com/en-us.

    Great result.

    People at Microsoft ¿do you all really use your own tools and read your web pages? ¿there isn't german, swedish, spanish, etc people at MS who suffer the same annoyances as us visiting msdn pages?


    Friday, October 17, 2014 6:07 PM
  • Please please please please Microsoft, turn off auto-translate!
    Monday, November 17, 2014 1:52 AM
  • On 7 July 2015 still active this useless annoying monster (:
    Tuesday, July 7, 2015 1:11 PM
  • In August 2015 this still sucks. Its even worse as the new website design not even has features to switch to the english original article. Bad work.

    • Edited by L_Herzog Tuesday, August 18, 2015 12:26 PM
    Tuesday, August 18, 2015 12:24 PM
  • Unfortunately your post is off topic here, in the MSDN Subscriptions feedback forum, because it is not feedback regarding the MSDN Subscription. This is only one forum among the many that are on the MSDN Discussion Forums, and given the content of your post, you likely chose the wrong forum. This is a standard response I’ve written up in advance to help many people (thousands, really.) who happen to post their question in my forum, but please don’t ignore it. The links provided below I’ve collected to help with many issues we’ve seen. 
    For technical issues with Microsoft products that you would run into as an end user of those products, one great source of info and help is http://answers.microsoft.com, which has sections for Windows, Hotmail, Office, IE, and other products. Office related forums are also here: http://office.microsoft.com/en-us/support/contact-us-FX103894077.aspx 
    If you really think your issue is related to the MSDN Subscription, and I screwed up, I apologize! Please repost your question to the discussion forum and include much more detail about your problem, that could include screenshots of the issue (do not include subscription information or product keys in your screenshots!), and/or links to the problem you’re seeing.  
    If you really have no idea where to post this question, then you shouldn’t have posted here, because we have a forum just for you! It’s called the ‘Where is the forum for…?’ forum and it's here: http://social.msdn.microsoft.com/forums/en-us/whatforum/ 
    Moving your post to the off topic forum. 

    Thanks,
    Sowmya
    MSDN Subscriptions Feedback
    Tuesday, August 18, 2015 6:31 PM
  • the new website design not even has features to switch to the english original article.

    I imagine it does.  Support has always had a link at the bottom which allows you to specify a different global location.  It still does.

    Unfortunately it looks like the link to it is in a frame so I can't give you its URL directly here.  FWIW I started here,

    https://support.microsoft.com/en-us

    javascript:function smcLanguageSelector() { return undefined; } smcLanguageSelector();

    then clicked on the English (United States) link that I saw at the bottom on the left and saw a page full of different languages.

    So, if yours says something else down there, click on that to see the page that I am referring to, then find (e.g. Ctrl-f) English in it and click on that.

    However, Support is a special case.  There are other Microsoft sites where you will need to add En-US to your Language preferences at the top of that list otherwise you will see the page implied by your top Language preference.

     

    FYI



    Robert Aldwinckle
    ---

    • Proposed as answer by L_Herzog Wednesday, August 19, 2015 3:15 PM
    Wednesday, August 19, 2015 2:32 AM
    Answerer
  • Thanks Robert. This helps. At least until the cookie is deleted. In the past you could switch it above the KB Article, now its at the very bottom. Not so handy.

    Wednesday, August 19, 2015 3:13 PM