none
Unable to reset the Number of Ratings for the Rating (0-5) field

    Question

  • I've created a set of workflows for an award program that move an item from an initial round of voting list to a second list. One of the workflows that runs on item creation in the target list has a command to "Set Rating (0-5) to 0.0". This successfully clears the amount of stars assigned to that item to 0. However, it's still displaying the number of votes that had been cast for it. For example, an item that was copied with an average rating of 3.5 and 12 ratings would display as 0|12 in the new list. I've added a a new line in the workflow to "Set Number of Ratings to 0," but this doesn't seem to have had any effect.

    Does anyone have any ideas towards resolution? I'm not sure if I need to affect the data in a different way, and if so, how.

    Tuesday, February 14, 2017 1:34 PM

All replies

  • Hi Ed_Similar,

    After you enable the rating in the list, it will add Rating(0-5), Number of Likes and Number of Ratings in the list columns.

    If you add Set Number of Ratings to 0 action in the workflow, it will not have any effect on Rating(0-5) column. It will set the value of Number of Ratings column to 0.

    Per my test in my SharePoint 2013 environment, it will just clear the number of the stars and not clear the number of the related person beside the star when adding Set Rating (0-5) to 0.0 action in workflow

    How did you copy the items from one list to another list? Did you copy the item by workflow?

    If you copy the items by workflow, you could create a new list, disable the rating in the list and copy the list items to the new list by workflow. After all items have been copied, then enable the rating in the new list. Then it will display 0|0 in the Rating(0-5) column.

    More reference:

    Add a ratings feature to your library.

    https://support.office.com/en-us/article/Add-a-ratings-feature-to-your-library-5901fcfd-19ca-4f27-a65f-284654298552

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 15, 2017 7:48 AM
    Moderator