none
[WP8.1]HubSections doesn't cycle to beginning with only 2 HubSections RRS feed

  • Question

  • Hi,

    I have windows phone 8.1 app and I want to use Hub control to show lists of items in sections, my sections represents groups and are dynamically grouped. Strange thing is when we have only 2 sections, Hub sections cycle don't stick to section corner and it don't go around. But if we have more that 2 sections everything works as expected in all examples it sticks and cycles around.

    Is this some kind of strange bug in framework is there any workarounds?

    More on this topic in stackoverflow: http://stackoverflow.com/questions/26147887/how-to-cycle-through-hubsections-in-windows-8-1-phone

    Looking for workarounds or confirmation if that is the planned "feature".

    Thanks.


    Tuesday, June 2, 2015 2:04 PM

All replies

  • Welcome to the Developing Universal Windows apps forum! 

    Please read the sticky posts, especially the Guide to posting: subject line tags and Known Issues for Windows 10 SDK and Tools 

    As noted in the S/O thread this is expected behaviour on Windows Phone 8.1.
    Tuesday, June 2, 2015 2:21 PM
  • Sorry did't read posting guidelines :)

    Search did not find any similar question so I don't know why I should read especially Windows 10 known issues.

    So are you saying that on WP8.1 expected behavior Hub with 2 section - don't cycle? Then maybe you could provide explanation why this behavior choice was made? Just curious why such strange choice?

    BTW S/O thread did not say that this is expected behavior on WP8.1, your citation: "Wrapping from Section <last> to Section 1 and vice versa is standard behavior on WP8.1. Check out an unchanged new Hub App. Not looping is expected on Windows (not-Phone) 8.1."

    You are saying that this is expected on Windows Store 8.1 not Windows Phone 8.1 :)

     
    Wednesday, June 3, 2015 4:29 PM