none
Small Basic Crashes RRS feed

  • Question

  • Hello,

    I am a teacher trying to use Small Basic in class.  Once myself or any of my students try to run any code, the program stops and crashes.  The error that we get is Microsoft Small Basic has stopped working.  A problem caused the program to stop working correctly.  Windows will close the program and notify you if a solution is available.  

    My computers are running Windows 8.1 with 2 GB of RAM.  I believe that we have all the necessary software installed.  Please advise on a solution as this is an awesome program that we would love to use.

    Batavia Domingue-Yost

    Technology Instructor

    Community Christian School

    Monday, March 2, 2015 4:38 PM

Answers

  • Hi,

    Did you follow correctly the article : http://social.technet.microsoft.com/wiki/contents/articles/23122.how-to-install-small-basic-onto-windows-8-1.aspx ?

    Is Small Basic running correctly while you don't run your programs ?

    Which kind of graphics card have you ? I know some computer like HP can have some trouble with the technology used by Small Basic.

    Another thing is to look in the Event Viewer (from the settings) if there are a message more explicit on what is crashing.

    Regards,


    Yan Grenier

    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont répondues à votre question, et de noter les réponses que vous avez trouvé utiles.

    Monday, March 2, 2015 5:18 PM
    Answerer
  • Had this problem two times (same error message) and made it working again with:

    * Check in taskmgr that SB.exe is closed.

    * Clean %TEMP% folder from all the *.pdb, tmp*tmp.exe and tmp*tmp files.

    * Delete all the 3 (WPF) FontCaches. Best from eg. CCleaner (& winapp2.ini), select 'Windows Presentation Foundation Font Cache *'

    * Also in CCleaner (incl. winapp2.ini) clean '.NET Assembly Temps *' and '.NET Framework Temp*'

    * Clean .sb Jumplists (all): Taskbar - Properties - Startmenu Tab - uncheck the CheckBox 'Show and save recently opened elements in taskbar and startmenu' (or similar? on an engl. system) - Apply. Maybe activate later again.

    * You can also temporarily stop or deactivate 'Windows Presentation Foundation-Fontcache' service.

    * Create a simple and correct, small  .sb file in eg. Notepad and try to compile it from the CmdLine with '%SB%\SmallBasicCompiler.exe Filename.sb' (from the sb file parent folder) and run the resulting exe.

    After all this steps SB worked again for me w/o problems.

    PS: Also check all your SB Extension.dll 's. There should not be a file like sameName.sb or sameName.exe in the same folder. Eg. you have LitDev.dll in a folder -> check that there's no LitDev.sb or LitDev.exe in the same folder.


    Wednesday, March 4, 2015 9:51 PM
    Answerer

All replies

  • Hi,

    Did you follow correctly the article : http://social.technet.microsoft.com/wiki/contents/articles/23122.how-to-install-small-basic-onto-windows-8-1.aspx ?

    Is Small Basic running correctly while you don't run your programs ?

    Which kind of graphics card have you ? I know some computer like HP can have some trouble with the technology used by Small Basic.

    Another thing is to look in the Event Viewer (from the settings) if there are a message more explicit on what is crashing.

    Regards,


    Yan Grenier

    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont répondues à votre question, et de noter les réponses que vous avez trouvé utiles.

    Monday, March 2, 2015 5:18 PM
    Answerer
  • Hello MommaBee-TeacherTechie,

    Similar error is described in the following thread. 

    https://social.msdn.microsoft.com/Forums/en-US/983e1a53-ab48-4997-b0b9-94f0fbdb3424/installation-problem-with-v03?forum=smallbasic


    Nonki Takahashi

    Wednesday, March 4, 2015 4:03 PM
    Moderator
  • Had this problem two times (same error message) and made it working again with:

    * Check in taskmgr that SB.exe is closed.

    * Clean %TEMP% folder from all the *.pdb, tmp*tmp.exe and tmp*tmp files.

    * Delete all the 3 (WPF) FontCaches. Best from eg. CCleaner (& winapp2.ini), select 'Windows Presentation Foundation Font Cache *'

    * Also in CCleaner (incl. winapp2.ini) clean '.NET Assembly Temps *' and '.NET Framework Temp*'

    * Clean .sb Jumplists (all): Taskbar - Properties - Startmenu Tab - uncheck the CheckBox 'Show and save recently opened elements in taskbar and startmenu' (or similar? on an engl. system) - Apply. Maybe activate later again.

    * You can also temporarily stop or deactivate 'Windows Presentation Foundation-Fontcache' service.

    * Create a simple and correct, small  .sb file in eg. Notepad and try to compile it from the CmdLine with '%SB%\SmallBasicCompiler.exe Filename.sb' (from the sb file parent folder) and run the resulting exe.

    After all this steps SB worked again for me w/o problems.

    PS: Also check all your SB Extension.dll 's. There should not be a file like sameName.sb or sameName.exe in the same folder. Eg. you have LitDev.dll in a folder -> check that there's no LitDev.sb or LitDev.exe in the same folder.


    Wednesday, March 4, 2015 9:51 PM
    Answerer