none
Adding support for an EDI version in R2 RRS feed

  • Question

  • I have a trading partner who wants to use an EDI version that isn't supported by the BizTalk 2006 R2 EDI adpater. Is it possible to add support for additional EDI standards versions to the R2 EDI adapter? How would I go about doing this?

    Thanks.
    Wednesday, August 13, 2008 3:05 PM

Answers

  • In the GS field properties you can specify 2010 or 2020 for version-specific fields. You will have to come up with the schemas yourself - either through modified BizTalk schemas or custom ones.

     

    Outside of the X12 version, I have wondered this question myself, about whether EDI messages can be sent which do not conform to the group of EDI messages in the ST1 drop down boxes.

     

    Thanks,

    Thursday, August 14, 2008 3:19 AM
    Moderator

All replies

  •  

    Which EDI version does your trading partner want to use?

    You can always contact product support at http://support.microsoft.com/contactus/?ws=support.

    Wednesday, August 13, 2008 9:02 PM
  • In this case, it would be the 2002FORD standards. I also have some others that use older versions of ANSI X12, 2010, 2020, etc. that may need to be added to BizTalk at some point.

    Is doing something like this possible without contacting customer support or would that be my only option?

    Thanks.
    Wednesday, August 13, 2008 9:23 PM
  • In the GS field properties you can specify 2010 or 2020 for version-specific fields. You will have to come up with the schemas yourself - either through modified BizTalk schemas or custom ones.

     

    Outside of the X12 version, I have wondered this question myself, about whether EDI messages can be sent which do not conform to the group of EDI messages in the ST1 drop down boxes.

     

    Thanks,

    Thursday, August 14, 2008 3:19 AM
    Moderator