none
Mail App Exchange version RRS feed

  • Question

  • Hi

    We've developed a Mail App for customer testing it using Exchange Online and use there item.saveAsync (https://msdn.microsoft.com/EN-US/library/office/mt269096.aspx) method that is defined in 1.3 schema. But deploying to customer's environment lead to an error with missing such a method. Customer has Exchange Server 2013 CU5 (15.0.913.22). Will upgrade to Exchange Server 2013 CU9 (15.0.1104.5) bring this new method? Or when will it be released? Is there any information about mapping of schema (1.1, 1.2, 1.3) and Exchange versions?

    What's also strange is that method from 1.3 is available in Online and documentation, but it's not possible to submit and app with min requirement of 1.3. Only 1.2. It' unacceptable to post information available only for Online without mentioning it.






    Tuesday, August 4, 2015 4:06 PM

Answers

  • Hi Yuri Leontyev,

    Based on my understanding, the Mail API version of 1.3 is represent the client Outlook API version (Outlook client, Outlook web app). It needs to Office runtime to support it. If the method can't work properly, we need to update the Office client to the latest version.

    Since the manifest was hosted on the Exchange, to use the latest version of manifest, we need to update the Exchange to the latest version. And to set the 1.3 version for MinVersion of mailbox, we need to use VersionOverrides element. You can get more detail about this from link below:
    Create a manifest for add-in commands

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Monday, August 10, 2015 9:04 AM
    Moderator

All replies

  • Hi Yuri Leontyev,

    Based on my understanding, the Mail API version of 1.3 is represent the client Outlook API version (Outlook client, Outlook web app). It needs to Office runtime to support it. If the method can't work properly, we need to update the Office client to the latest version.

    Since the manifest was hosted on the Exchange, to use the latest version of manifest, we need to update the Exchange to the latest version. And to set the 1.3 version for MinVersion of mailbox, we need to use VersionOverrides element. You can get more detail about this from link below:
    Create a manifest for add-in commands

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Monday, August 10, 2015 9:04 AM
    Moderator
  • Hi Yuri. I'm facing the same problem. Have you found a reference of Exchange versions to office javascript api version?

    We updated Exchange to 15.0.847.41 and it still doesn't support 1.3 of the office javascript api.  There is one newer version that was just released a day or two ago, but I'd like to know if it supports 1.3 before upgrading.

    Thanks,

    Todd

    Friday, September 18, 2015 3:58 PM