none
Issue with Oracle Adapter RRS feed

  • Question

  • Hello All,

    Recently i posted a question (http://social.msdn.microsoft.com/Forums/en-US/biztalkr2adapters/thread/f948d00a-308c-46c8-9898-daee4be956fd/) which i was able to solve and works fine using c#.Net.

    Now i need to use Oracle adapter. So, i created the DNS using ODBC which uses 9.02.00.00 odbc driver. Then i tested the connection via ODBC and it is success. Then, i created a send port and pointed the same DNS name and tried generating a schema. This time am getting error:

    "Exception occurred:Error Code: 12154 (0x2f7a) 08004 : [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve service name".

    I tried the same way in another machine and i am able to generate the schema.It uses 9.02.00.65 ODBC driver and it is 32-Bit server. But the one which am trying is 64-bit server and it uses 9.02.00.00 ODBC driver.

    Pls let me know if there is a solution.

    Thanks in advance.
    BizTalk Beginner
    Monday, March 8, 2010 1:43 PM

All replies

  • Hi BizTalk Beginner,

    What I understand is that you have problem with Oracle Adapter (non-WCF), which you want to use in 64-bit environment. ODBC connection test in 64-bit environment works, correct? I assume you work with BizTalk 2006 (R2) with 64bits Windows 2003. If so you can look at this post to resolve your issue: http://blog.wadewegner.com/index.php/2007/05/04/the-biztalk-adapters-for-enterprise-applications-on-windows-server-2003-64-bit/ or http://blog.wadewegner.com/index.php/2007/03/09/using-the-odbc-adapter-for-oracle-database-in-biztalk-2006/. Let me know if this helps.

    Regards,

    Steef-Jan Wiggers
    (http://soa-thoughts.blogspot.com/)
    If this answers your question please mark it accordingly.


    BizTalk
    Monday, March 8, 2010 2:17 PM
    Moderator
  • Which version of the adapter pack v1 or v2 are you using?

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, March 8, 2010 3:15 PM
    Moderator
  • Hi Steef,

    You are correct. I am using exactly same server/oracle client combination as you mentioned above.

    I changed the registry settings. But still am facing the same problem.

    I am able to connect via the SQL Plus using the DNS name created using the ODBC. Also i created a receiveport and used exactly the same settings i used in send port. Then i clicked the Managed Events. I can see the tables to my strange. But if i use the send port to generate the schema, am getting this wierd error "TNS: Could not resolve the service name.
    Actully i changed the policy.9.2.Oracle.DataAccess.config file to use the ODP.Net 9.2 client during the runtime. Because, the server is 8i, and the clients installed are 9i,10g and 11g. So, whenever am attempting to connect, it uses the 11g (latest) client and throws error that "This version is not supported". So i updated the policy file to point to the 9i client, if the request is from 9.2 oracle.dataaccess.dll. It is working fine using c#.Net. But the issue is with when am using the Oracle adapter.

    Do i need to re-start the server?

    How to check which version of the adapter pack is installed?

    BizTalk Beginner
    Tuesday, March 9, 2010 12:35 PM
  • Hi,

    Restart can be option to change behaviour. To check which version is installed you have use regedit and look for computer\HKEY_LOCAL_MACHINE\Software\Microsoft\BizTalk Adapter Pack there you will see if it is for instance 1.0 or 2.0 (WCF based) if it is non-WCF than it will not find this key, but computer\HKEY_LOCAL_MACHINE\Software\Microsoft\BizTalkAdapters.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Tuesday, March 9, 2010 7:10 PM
    Moderator
  • Hi Steef,

    Restart also didnt work out. I guess its not an issue with the adapter. As, i am able to view the DB & Table details when i created a Receive Port and used the Managed Events where it is populating all the necessary details. Do we need to do anything in the VS? Because, After i changed the policy file, i change the .Net project Build from "Any CPU" to "x86" inorder to get it work for C#.Net application. Simillarly, do we need to do anythng settings change in VS?

    Thanks in advance...
    BizTalk Beginner
    Thursday, March 11, 2010 2:55 AM