none
Target Designer RRS feed

  • Question

  • Hi,
    Embedded Standard: 
    I'm trying to build the image but as soon as I hit the build button a dialogue box appears asking me if i want to erase the build folder and i hit Yes. Then i get an error message saying i don't have permission for this folder.  I'm running as administrator.  If i close target designer then i can delete the files, namely the build log.  Running on Xp professional.  Can anyone help please?

    Thursday, March 19, 2009 1:14 PM

All replies

  • Are you building the image to a folder - Windows Embedded Images or the root of a partition?

    If the later, I would switch this back to a folder and just copy the image from the folder to the partition. IN a partition there is the system volume folder that cannot be deleted, unless the parition is reformated.

    -Sean

    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit
    Friday, March 20, 2009 6:45 PM
    Moderator
  •  Hi Sean,

    Thanks for your answer.  I'm building to a subfolder in Windows Embedded Images.  I was getting this error even though i had never built an image yet.  The problem seems to be with the build logfile itself which Target Designer put there previously.  However saving the log file folder to a network folder seems to have cured the problem.

    Thanks again
    Saturday, March 21, 2009 4:55 PM
  • The log file cannot be located in the same directory as the image being built. Locating the log file to a different directory will prevent this from happening. Check Tools->options to preset a location.

    -Sean

    www.sjjmicro.com / www.seanliming.com, Book Author - XP Embedded Advanced, XPe Supplemental Toolkit
    Sunday, March 22, 2009 3:22 AM
    Moderator