none
[EWS] Broken contact entries RRS feed

  • Question

  • I have an EWS application (using direct XML, not the library) that will create contact entries in Exchange.  Was working fine.  Now when I try to view my created contact in the new version of OWA (for an Office 365 account) the contact is mostly broken.  All that shows up is the company name.  Further, I cannot delete the entry - I get an error message saying that it cannot be deleted now, try again in a few minutes (it never works).  Further information - when I connect to this account using Outlook 2010, the entries look fine, no missing properties, can be deleted no problem.  I've included a minimal xml sample below that generates this behavior.  Any ideas?

    <SavedItemFolderId>
    <t:FolderId Id="AAMkADVlZDZhYjk1LWIyODktNDg5Ni1hMjM2LTNhOTU3OGMwMjIzOQAuAAAAAAAXWBPWqu+KS7Pyzs2vmZejAQBRz1Ef92XaTpGC6Dk4W9DeAAAAYQ7dAAA="/>
    </SavedItemFolderId>
    <Items>
    <t:Contact>
    <t:Categories>
    <t:String>Blue Category</t:String>
    </t:Categories>
    <t:ExtendedProperty>
    <t:ExtendedFieldURI PropertyTag="0x3004" PropertyType="String"/>
    <t:Value>via TM</t:Value>
    </t:ExtendedProperty>
    <t:FileAs>John Hieb</t:FileAs>
    <t:GivenName>John</t:GivenName>
    <t:CompanyName>Transend</t:CompanyName>
    <t:EmailAddresses>
    <t:Entry Key="EmailAddress1">john.hieb@transend.com</t:Entry>
    </t:EmailAddresses>
    <t:Surname>Hieb</t:Surname>
    </t:Contact>
    </Items>
    

    Wednesday, March 27, 2013 12:04 AM

All replies

  • Further to this, I found that I can get it working by changing the server name to outlook.office365.com.

    I had been using pod51008.outlook.com.  I don't really understand the architecture of Office 365 now - how can they have a single server to handle everybody? 

    Wednesday, March 27, 2013 3:20 AM