locked
Problem of web site ASP - C# integration and deployment on server web RRS feed

  • Question

  • User-458598543 posted

    Hello guys,

    I've got a problem of integration and deployment of my website on server web.

    The web site is developed with visual studio 2015. I created a C# webforms aspx project. I builded the project and I copied all the files in a folder on a server web IIS.

    The configuration of the site with his files in IIS is good but the problem is when I'm trying to launch the web site on internet Navigator, I've got the following error message :

    "" The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly. Requested URL: / ""

    Great for your solution !

    God trust

    Thursday, August 3, 2017 12:39 PM

Answers

  • User1771544211 posted

    Hi Rednuts72,

    Rednuts72

    "" The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly. Requested URL: / ""

    The 404 Not Found error indicates the path you request doesn't have related item, please check the url you request and make sure there is the aspx existing in the physical path.

    And you can enable the detailed error page in IIS to display more detailed error message about this issue.

    https://blogs.msdn.microsoft.com/rakkimk/2007/05/25/iis7-how-to-enable-the-detailed-error-messages-for-the-website-while-browsed-from-for-the-client-browsers/

    Rednuts72

    I like to know where can I put the name of the 1st page in IIS Service or WebConfig page to launch the web site ?

    The 1st page is "WF1_Accueil.aspx".

    Do you mean that you want to set the "WF1_Accueil.aspx" page as the default page of the application, when you type the url like http://domain:port it will auto show the "WF1_Accueil.aspx"?

    You can find how to set the default document in the following link.

    https://docs.microsoft.com/en-us/iis/configuration/system.webServer/defaultDocument/

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, August 4, 2017 2:45 AM
  • User-458598543 posted

    Hello,

    I find the solution, As I use IIS Service, I pointed (associated) the web site url to the files folder in contextual menu "Add WebSite" and textbox field "Host Name".

    Happiness ...

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 8, 2017 6:53 PM

All replies

  • User753101303 posted

    Hi,

    Seems a problem with the default document as it complains about the / location. What if you try to enter the exact full url for your home page?

    You could also try to add a test.htm file and see if you can reach it. Also the application pool is configured to handle ASP.NET ? See https://technet.microsoft.com/en-us/library/cc754523.aspx

    Thursday, August 3, 2017 12:58 PM
  • User-458598543 posted

    Hello,

    I think that the problem comes about the cancelled webpage pointer. With the présents parameters, the 1st page of the web site is not launched.

    I like to know where can I put the name of the 1st page in IIS Service or WebConfig page to launch the web site ?

    The 1st page is "WF1_Accueil.aspx".

    Thursday, August 3, 2017 1:10 PM
  • User1771544211 posted

    Hi Rednuts72,

    Rednuts72

    "" The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly. Requested URL: / ""

    The 404 Not Found error indicates the path you request doesn't have related item, please check the url you request and make sure there is the aspx existing in the physical path.

    And you can enable the detailed error page in IIS to display more detailed error message about this issue.

    https://blogs.msdn.microsoft.com/rakkimk/2007/05/25/iis7-how-to-enable-the-detailed-error-messages-for-the-website-while-browsed-from-for-the-client-browsers/

    Rednuts72

    I like to know where can I put the name of the 1st page in IIS Service or WebConfig page to launch the web site ?

    The 1st page is "WF1_Accueil.aspx".

    Do you mean that you want to set the "WF1_Accueil.aspx" page as the default page of the application, when you type the url like http://domain:port it will auto show the "WF1_Accueil.aspx"?

    You can find how to set the default document in the following link.

    https://docs.microsoft.com/en-us/iis/configuration/system.webServer/defaultDocument/

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, August 4, 2017 2:45 AM
  • User-458598543 posted

    Hello,

    I find the solution, As I use IIS Service, I pointed (associated) the web site url to the files folder in contextual menu "Add WebSite" and textbox field "Host Name".

    Happiness ...

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, August 8, 2017 6:53 PM