locked
Messages stuck in mailroot/queue folder RRS feed

  • Question

  • User1666227136 posted

    I have a virtual SMTP server setup that has been running for months without a problem.  It's acting as a relay to send messages to smtp.mandrillapp.com.  Suddenly, on 6/10 it just stopped working.  After tons of troubleshooting nothing seemed to fix it.  Many have said to try and telnet into the smtp.mandrillapp.com which I cannot do, but I can telnet from every other computer we have.  Then on 6/15 about 1/2 way through the day, it just started sending again.  Crazy...  What happened?  What changed?  I never did figure it out.  Well, who cares right, it works now...

    Then, just yesterday, it quit again.  And once again, I can't get it going.  I tried using a tool I found called SMTP Diag Tool.  When I connect to that local SMTP server it appears to send just fine, however, it's still stuck in the queue folder.  When I tried to use that tool from that server to connect directly with smtp.mandrillapp.com it did not work.  The log from tool just says

    Connecting to mail server.

    Error: Timeout.
    Failed to send message

    I tried that same tool on a Windows 10 PC and it worked perfectly.

    Any ideas of what I can check?

     

    Tuesday, June 23, 2020 8:46 PM

All replies

  • User-848649084 posted

    Hi,

    could you please share On which OS this issue happen? you could try below setting to resolve the issue:

    SMTP Virtual Server > Properties > Delievery > Outbound Connections->uncheck the option for Limit number of connections.

    restart the SMTP service.

    Wednesday, June 24, 2020 2:56 AM
  • User1666227136 posted

    This is a Windows 2016 Standard Edition server.

    And, I did try that fix you recommended but that didn't work either. 

    Yesterday after I posted this question, about an hour later the emails just started to release again.  Right now it appears to be working fine but I wonder for how long?

    Wednesday, June 24, 2020 1:33 PM
  • User-848649084 posted

    sometimes mail server banned some action due to this cause it is stuck in queue after restarting server or SMTP service will resolve the issue.

    Friday, June 26, 2020 9:02 AM
  • User-848649084 posted

    Hi,

    Is your issue solved?

    If your issue is solved then I request you to mark the helpful suggestion as an answer. This will help other people who face the same issue.

    If your issue still exists then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Jalpa.

    Friday, July 10, 2020 3:18 AM