locked
assembly windowsbase RRS feed

  • Question

  • hello,
    i get a strange error when i try to install an app:

    unable to install or run the app.the app requires that assembly windowsbase version 3.0.0.0 be installed in the
    global assembly cache (GAC) first.


    i made a reference to windowsbase but still no effect

    thank you
    Tuesday, September 18, 2007 7:43 AM

Answers

  • i managed to resolve it:

    you just drag and drop windowsbase.dll to c:\windows\assembly on the machine you want the app to work.

    hope you understand Smile
    Tuesday, September 18, 2007 8:57 AM

All replies

  • i managed to resolve it:

    you just drag and drop windowsbase.dll to c:\windows\assembly on the machine you want the app to work.

    hope you understand Smile
    Tuesday, September 18, 2007 8:57 AM
  • Not a solution, I can't tell my users "Ok, just install this Windowsbase thingy before you run our install program".

     

    Your average "user" can't deal with that.

     

    -Matt

    Monday, July 7, 2008 3:44 PM
  •  

    hi i have the same problem did you ever find a soution ?

     

    Friday, October 3, 2008 4:24 PM
  • Hi

     

    I have the same problem. Did you find a solution?

    Douglas

    Thursday, January 22, 2009 12:33 PM
  • I have the same problem. ClickOnce deployment seems to not be able to bootstrap the .NET 3.0 framework.
    Has anyone figured out how to get this to work?
    Tuesday, May 26, 2009 11:57 AM
  • similar situation
    got this error on a fresh xp pro install/ downgrade from vista home premium
    was using net 2.0
    installed .net 3.0, no more problem.
    hope that helps
    ymmv
    Friday, July 3, 2009 1:43 AM
  • You can find WindowsBase.Dll in C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0

    WR
    Wednesday, December 2, 2009 9:48 PM
  • True, you can find the WindowsBase.Dll file in the 

    C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0

    folder, but only if you have the .NET 3.0 framework installed. So the solution if you don't have the framework is to go to:

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043#QuickInfoContainer

    to download the framework.


    Wednesday, August 25, 2010 9:31 PM
  • This is bullsh*&. I though .net was going to do away with this nightmare.
    Wednesday, February 23, 2011 9:55 PM