locked
HTTP Error 500.19 - Internal Server Error RRS feed

  • Question

  • User2067508032 posted

    Hi all,

    I found "HTTP Error 500.19 - Internal Server Error" in my localhost.

    Actually this program is I using everyday this morning when I run program I found it.

    Detailed Error Information:
    Module	           IIS Web Core
    Notification	   Unknown
    Handler	           Not yet determined
    Error Code	   0x80070003
    Config Error	   Cannot read configuration file
    Config File	   \\?\C:\Users\Admin\Documents\My Web Sites\test-Site\web.config
    Requested URL	   http://localhost:49231/test/Login.aspx
    Physical Path	   
    Logon Method	   Not yet determined
    Logon User	   Not yet determined
    Request 
    Tracing Directory C:\Users\Admin\Documents\IISExpress\TraceLogFiles\
    Config Source:
    
       -1: 
        0: 
    
    


    pls adivce to me. Thanks advance

    Thursday, January 16, 2014 2:40 AM

Answers

  • User2067508032 posted

    Hi Dear all,

    Thanks you for reply me. I can solve error but I don't understand yet.

    Some is my fault when I clean my computer, I delete this path of some folder Tongue Out " C:\Users\Admin\Documents\My Web Sites\ ".

    After that I suspect and create myself new fold. My appliction now working well.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, January 19, 2014 9:39 PM

All replies

  • User-1454326058 posted

    Hi dragular,

    Thanks for your post!

    Based on the error message, I can find the web site path is in the user’s folder.

    As far as I know, by default the worker processes run as NETWORKSERVICE account. For that account, it don’t have the permission to access the file which path in the user’s folder.

    One way is that, you could let the project in the different place, such as D:\\Project (Copy the project to the other place)

    Another way is that, you could configure the Application Pool’s Identity use the specified account that has the enough permission to access the user’s folder.

    1. Right click the Application pool that the website used.
    2. Select Advanced Setting
    3. Change the Identity (In the Process Model section)

    There is a link that may benefit you:

    # Application Pool Identities

    http://www.iis.net/learn/manage/configuring-security/application-pool-identities

    Thanks

    Best Regards  

    Friday, January 17, 2014 12:36 AM
  • User71929859 posted

    Right click on your web application folder and go to properties (From file explorer). Then select the security tab. Give read permission to IIS_IUSR.

    Sunday, January 19, 2014 3:46 AM
  • User2067508032 posted

    Hi Dear all,

    Thanks you for reply me. I can solve error but I don't understand yet.

    Some is my fault when I clean my computer, I delete this path of some folder Tongue Out " C:\Users\Admin\Documents\My Web Sites\ ".

    After that I suspect and create myself new fold. My appliction now working well.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, January 19, 2014 9:39 PM