locked
Publish website visual studio 2012, iis 7, web deploy RRS feed

  • Question

  • User-102142069 posted
    Im having trouble to publish my website using web deploy, always gets an syncronization error and I think its because I got a folder in the web project were people can upload pictures. My quiestion is how do i config the web deploy service to not syncronize these folders?
    Friday, September 14, 2012 8:25 AM

Answers

All replies

  • User-176674611 posted

    If what you are publishing is a web application project, you may take reference to the below guide:

    Web Deployment: Excluding Files and Folders via the Web Application’s Project File
    http://blogs.msdn.com/b/webdev/archive/2010/04/22/web-deployment-excluding-files-and-folders-via-the-web-application-s-project-file.aspx

    However, if it was a web site project, then the above option will not be available. And as far as I know, you will need to exclude the folder from your project to skip the folder for synchronization.

    Thanks.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 18, 2012 10:38 PM
  • User-102142069 posted

    If what you are publishing is a web application project, you may take reference to the below guide:

    Web Deployment: Excluding Files and Folders via the Web Application’s Project File
    http://blogs.msdn.com/b/webdev/archive/2010/04/22/web-deployment-excluding-files-and-folders-via-the-web-application-s-project-file.aspx

    However, if it was a web site project, then the above option will not be available. And as far as I know, you will need to exclude the folder from your project to skip the folder for synchronization.

    Thanks.

    The problem is that the images isn't in the Web App solution they are only on the server "content" folder. But I think Web Deploy are trying to syncronize these files every time I make a deploy. I want Web Deploy to skip these folders because they dont have nothing to do with my Web App. How can I then skip the folder for synchronization?
    Wednesday, September 19, 2012 6:15 AM
  • User-176674611 posted

    You may skip the folder if you use the msdeploy command line. For visual studio publishing, have you tried set the folder property to hidden? I mean windows explorer -> right click the folder -> properties -> select hidden. After doing that refresh the solution and try publish. See if the synchronization for the folder still happens in this case.

    Thanks.

    Friday, September 21, 2012 4:01 AM