none
Retina support in Bing Maps AJAX v7 RRS feed

  • Question

  • When showing the Bing Maps Ajax Control v7 in a webview on an iPad 2+ or iPhone 4+, it doesn't take advantage of the Retina resolution. How do I enable this?
    Sunday, October 21, 2012 9:12 PM

Answers

All replies

  • Retina resolution support is not a supported feature of the Bing Maps V7 AJAX control.


    http://rbrundritt.wordpress.com

    • Marked as answer by Ricky_Brundritt Monday, October 22, 2012 8:33 AM
    • Unmarked as answer by Mike Sax Wednesday, October 31, 2012 5:00 AM
    • Marked as answer by Ricky_Brundritt Monday, November 5, 2012 5:13 PM
    Monday, October 22, 2012 8:33 AM
  • Thanks Richard, however... according to this article on the Bing website, the Bing London Get Me There app uses the Bing Maps v7 AJAX control. When I run that app on a retina iPhone it clearly takes advantage of the retina display. The Bing native iOS control is no longer supported and lacks support for the iPhone 5 processor, so I'd really like to get this working.
    • Edited by Mike Sax Wednesday, October 31, 2012 4:58 AM
    Wednesday, October 31, 2012 4:57 AM
  • The team that built the Bing Get Me there app did nothing to the Bing Maps control to get it to support retina display.


    http://rbrundritt.wordpress.com

    Monday, November 5, 2012 5:13 PM
  • Richard,

    They had to have done something different. The map looks crystal clear in the Get Me There app. When you browse to maps.bing.com on a Retina device, it's blurry. How do you explain the very apparent difference in quality between the two?

    Wednesday, November 21, 2012 7:03 PM
  • Maybe try giving the viewport metatag a chance:

    <meta name="viewport" content="width=device-width, initial-scale=1.0"/> 

    Some info about this: http://davidbcalhoun.com/2010/viewport-metatag

    http://rbrundritt.wordpress.com

    Wednesday, November 21, 2012 7:16 PM
  • We're already using the viewport metatag, as is maps.bing.com. Still seeing low-quality tiles.
    Wednesday, November 21, 2012 7:43 PM
  • Hi, I know this was a loong time ago, but have you ever resolved the problem with the blurred tiles ? cheers
    Saturday, September 19, 2015 12:32 AM
  • Try setting the map option enableHighDpi to true. https://msdn.microsoft.com/en-us/library/gg427603.aspx

    http://rbrundritt.wordpress.com

    Monday, September 21, 2015 4:55 PM