locked
HTTP Error 404.3 - Not found IIS7 RRS feed

  • Question

  • User-1677895288 posted

    I have an Windows 2008 server with IIS 7 installed.

    I am trying to move a web site that was using classic asp and hosted on a IIS 5 server to the new machine.

    When I try to call the asp page: "http://ServerName/Web Site/Home.Asp I am getting this error:

    "HTTP Error 404.3 - Not found

    "The page you are reqquesting cannot be served because of extension configuartion. If the page is a script, add a handler. If the file should be downloaded, add a MIME map"

    I go to "script map", and enter:

    Request path: *.asp

    Executable: C:\Windows\Microsoft.NET\Framework\V2.0.50727\aspnet_isapi.dll

    When I click OK, I get this message:

    "Do you want to allow this ISAPI extension?...etc

    I click yes and I get the error:

    "The specified module required by this handler is not in the modules list, etc, etc.

    Now I am lost..

     

    Thanks 

     

    Friday, June 4, 2010 6:53 PM

Answers

  • User-1653247517 posted

    Go to server manager and install asp component if it is not already installed. That might create the right handler mapping. If it doesn't, change the handler you created to make it use c:\windows\system32\inetsrv\asp.dll. Let me know what you see then.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, June 4, 2010 7:32 PM
  • User744767459 posted

    Hi,

    By default, script errors no longer shown in browser. You can follow the procedure in the article below to troubleshooting this issue:

    Tips for Classic ASP developers on IIS7

    http://blogs.iis.net/bills/archive/2007/05/21/tips-for-classic-asp-developers-on-iis7.aspx

    Thanks.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, June 9, 2010 2:16 AM

All replies

  • User-1653247517 posted

    Go to server manager and install asp component if it is not already installed. That might create the right handler mapping. If it doesn't, change the handler you created to make it use c:\windows\system32\inetsrv\asp.dll. Let me know what you see then.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, June 4, 2010 7:32 PM
  • User-1677895288 posted

    Yes I was missning some components. When I installed the rest of them, it worked fine now!

    Friday, June 4, 2010 7:43 PM
  • User-1677895288 posted

    When I am calling the asp pages from the IIS server itself, it works fine. But If I call the pages form the another client, I am getting the error:

    500 - Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed.

    It sounds like an authentication issue??

    Friday, June 4, 2010 7:55 PM
  • User744767459 posted

    Hi,

    By default, script errors no longer shown in browser. You can follow the procedure in the article below to troubleshooting this issue:

    Tips for Classic ASP developers on IIS7

    http://blogs.iis.net/bills/archive/2007/05/21/tips-for-classic-asp-developers-on-iis7.aspx

    Thanks.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, June 9, 2010 2:16 AM
  • User715110082 posted
    is there a different executable for asp handler if you configure your application to enable 32 bit ?
    Thursday, June 17, 2010 3:33 PM
  • User736847239 posted

     I had everything installed. Tried uninstalling and reinstalling, with no luck. I've searched everywhere and am out of ideas.

    Thursday, June 17, 2010 5:55 PM
  • User744767459 posted

    Hi,

    You can send the applicationhost.config to me at: liangliang.tang(at)hotmail.com, I'll try reproduce your issue. Thanks.

     

    Sunday, June 20, 2010 7:47 AM
  • User736847239 posted

    Leo,

    Thanks for your offer to help!!!

    After a 2nd uninstall and re-install, I was able to get Classic ASP working with *.asp pages. Unfortunately I inherited this site and it has many *.html pages that have classic ASP within. When I add "*.html" to the Request Path of the ASPClassic Handler Mappings, I thought it would handle the ASP for those pages, but instead it introduced some errors.

    For the true ASP pages (e.g. index.asp) I get a 404 File or Directory Not Found error.
    For the HTML pages with ASP it continues to not process the ASP and also the CSS for the page doesn't load.

    Monday, June 21, 2010 12:26 PM
  • User736847239 posted

     I finally got this to work too. Yeah!!!

     I made a separate entry into the HandlerMappings, i.e. ASPClassicHTML and then eidted the applicationHost.config file and removed the preconditions.

    <add name="ASPClassicHTML" path="*.html" verb="GET,HEAD,POST" modules="IsapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="File" requireAccess="Script" />

     

    Monday, June 21, 2010 1:17 PM