locked
Added Office Workload - Solution no longer works RRS feed

  • Question

  • User438705957 posted

    I have an existing solution with two projects..
    I noticed I didn't have the Office/SharePoint workload installed so I launched the installer while the current project was open.

    The installer went through its thing installing the Office workload and then prompted me to restore files from the current project I had open.
    I found this odd and selected to restore the files.

    Visual Studio then rebooted to the start page.
    I opened my original solution, and only one of the projects, the data layer, was visible. I right clicked on the solution and added 'existing' project to get the other project back.

    I attempted to run Index.cshtml in debug mode and was greeted with:
    A default document is not configured for the requested URL, and directory browsing is not enabled on the server.

    The original solution ran IIS Express on this port http://localhost:51306/Home/Index
    The new solution now runs it on this http://localhost:51375/
    i.e. there is a change of port number from 51306 to 51375, which I think is the cause of the problem.

    I can right click on the file in solution explorer and elect it to run in the browser, and it works on the old port 51306.
    But I can't run it at all in debug mode from the debug menu.

    Thanks for considering 

    Thursday, November 15, 2018 10:54 PM

All replies

  • User283571144 posted

    Hi Madog,

    Could you please tell me the version of the VS you have used now? VS2017 or VS2015?

    How you install the workload? From the VS2017 installer?

    If you could post more details information, it will be more easily for us to reproduce your issue and find out the solution.

    Best Regards,

    Brando

    Monday, November 19, 2018 9:09 AM
  • User438705957 posted
    Hi Brando,
    I am on VS 2017 and I launched the workload update from within VS. I think I should have closed the current solution before proceeding.
    Thanks
    Thursday, November 22, 2018 8:15 AM