locked
HTTP Error 500.19 - Internal Server Error 0x80070003 RRS feed

  • Question

  • User260296362 posted

     Hi all!

     I know the topic is very common in ISS but I couldn't solve it with what I found so far.

    I have got IIS7 running on my Windows 2008 Server SP2 x64. It works perfectly when I have my websites located in the standard C:\inetpub\

    Because of the way my machine is set up, I need to relocate the website to a network drive, that being Z:\WWWROOT\inetpub\wwwroot . Z is the network drive. No credentials are needed to access the drive.

     When I copy the path above in my browser the folder containing the index.htm is displayed correctly.(in firefox, not in IE)

    I have correctly set the IIS_IUSRS permissions on the site folder (and just in case, I made a new site folder via IIS so it set it's own permissions) yet I keep getting the error:

    Error Summary

    Internet Information Services 7.0

    <fieldset><legend>Error Summary</legend>

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    </fieldset>
    <fieldset><legend>Detailed Error Information</legend>
    Module IIS Web Core
    Notification Unknown
    Handler Not yet determined
    Error Code 0x80070003
    Config Error Cannot read configuration file
    Config File \\?\Z:\WWWROOT\inetpub\wwwroot\web.config
    Requested URL http://192.168.0.11:80/
    Physical Path
    Logon Method Not yet determined
    Logon User Not yet determined
    </fieldset>
    <fieldset> <legend>Config Source</legend>
       -1: 
    0:

    </fieldset>

     

    Thanks in advance for a solution!

     

    Regards

    Thursday, May 28, 2009 9:52 AM

Answers

All replies

  • User797879709 posted

    The issue isn't permissions or access at this point.  IIS is unable to read the configuration file in the path specified.

     Try copying, then deleting the web.config file and see if that solves your serving problem.  If it does, then use the IIS UI to navigate to the website and pinpoint the config error.

    Thursday, May 28, 2009 10:43 AM
  • User260296362 posted

     Thanks for your reply but haven't got a file web.config.

    I eventually even searched my C: for it and didn't find it. 

    Thursday, May 28, 2009 11:23 AM
  • User797879709 posted

    According to the error you've posted it has these two lines:

    Config Error Cannot read configuration file
    Config File \\?\Z:\WWWROOT\inetpub\wwwroot\web.config

    Does a web.config file exist at this path?
    Z:\WWWROOT\inetpub\wwwroot\web.config

    Thursday, May 28, 2009 11:26 AM
  • User260296362 posted

     For sure there isn't. I nowhere have a web.config on my system nor on my network drive (X:). When I use C:\inetpub it works fine although there's no web.config either.

     Thx in advance !

    Thursday, May 28, 2009 11:39 AM
  • User797879709 posted

    Can you double check the permissions on the Z:\WWWROOT\inetpub\wwwroot\ folder?  IIS_IUSRS needs Read & Execute, List Folder Contents and Read permissions.

    Maybe the worker process can't correctly access the folder?  That's my next guess.

    Thursday, May 28, 2009 11:52 AM
  • User260296362 posted

     Wasn't the case for that specific dir, changed it but the problem persists! Same error message.

    Thx

    Thursday, May 28, 2009 11:58 AM
  • User511787461 posted

    You cannot point IIS to a mapped network drive since the mapped network drive only exists in your session, not the session IIS is running as - use the \\server\share syntax to point IIS to a network drive and configure a username/password to connect to that drive if needed.

    Thursday, May 28, 2009 12:54 PM
  • User260296362 posted

     Thx for you reply, how would that look like in my case? I tried...

    Config File\\?\Z:\WWWROOT\inetpub\wwwroot\

    Thanks in advance

    Friday, May 29, 2009 3:11 AM
  • User511787461 posted

    You must have done "net use z: \\server\share" - instead of using z:, use \\server\share in the IIS configuration - so \\server\share\wwwroot\inetpub\wwwroot - also may need to specify username/password in "connect as".

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, June 1, 2009 11:09 AM
  • User260296362 posted

      Thanks but I keep on getting an 500.19 error: I made a user with admin rights on the 192.168.0.40 machine and I'm logged on with this credentials. I used the \\server\share\... as you suggested. Still:

    <fieldset><legend>Error Summary</legend>

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    </fieldset>
    <fieldset><legend>Detailed Error Information</legend>
    Module IIS Web Core
    Notification Unknown
    Handler Not yet determined
    Error Code 0x8007052e
    Config Error Can not log on locally to \\192.168.0.40\Volume_1\inetpub\wwwroot as user \\192.168.0.40\Volume_1\wwwrootuser with virtual directory password
    Config File Unavailable (Config Isolation)
    Requested URL http://192.168.0.11:80/
    Physical Path
    Logon Method Not yet determined
    Logon User Not yet determined
    </fieldset>
    <fieldset><legend>Config Source</legend>
                    <application path="/">
    <virtualDirectory path="/" physicalPath="\\192.168.0.40\Volume_1\inetpub\wwwroot" userName="\\192.168.0.40\Volume_1\wwwrootuser" password="[enc:AesProvider:S9FRXhSPCENhWQXjBzMNdQBxzKtuAXRI2f2Q3a0X7gPc//yJUwLsTItYL8N6GKXO:enc]" logonMethod="ClearText" />
    </application>
    </fieldset>
    <fieldset><legend>Links and More Information</legend>This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.

    View more information »

    </fieldset>
    Tuesday, June 2, 2009 9:24 AM
  • User511787461 posted

    Pretty sure that \\192.168.0.40\Volume_1\wwwrootuser is not a valid username.

    Tuesday, June 2, 2009 12:23 PM
  • User1574399284 posted

    This might not help, but I wanted to comment that I spent hours on this same error and found the solution to my problem. It turned out to be something that nobody else ever documented, so I'm trying to spread the word for Google.

    It turned out that my root web was working fine, but my subwebs were not working fine and I got this error for the subweb. The subweb was an individually configured ASP.NET application. I figured that this wasn't important because the root web was just a flat HTML file, but it mattered.

    What happened in my case was that a few days ago I had relocated the root web, then updated IIS to point to the new directory. All of the subweb applications, however, were treated by IIS as virtual directories, each with its own physical directory mapping. So each had the stale path.

    More specifically, I moved "C:\web\www.mysite.com" to "C:\web\mysite.com", updated IIS for MySite to point to \web\mysite.com, and left it as such. The applications under mysite.com were each pointing to C:\web\www.mysite.com\[application].

    I had to update each subweb application's Basic Settings to point to the revised path, and the 500.19 error went away.

    Hope this helps others like it would've helped me.

    Jon

    Sunday, June 21, 2009 5:18 PM
  • User1254222884 posted

    Hmmm. I'm getting the same error message, different details.  In my case, it says the config file is located at \\?\c:\inetpub\wwwroot\ProjectFiles\dev.site.com\web.config

    Not sure why it says that: there is no ProjectFiles directory (there used to be, but it was for a totally different project).  So why is this site pointing to a non-existent directory for a different project? AND, how the BLEEP do I tell it NOT TO LOOK THERE?!?!?!

    Weird!

    Wednesday, August 29, 2012 1:32 PM
  • User154428540 posted

     This error is one I have received as well, although I did mine on purpose.

     

    To fix this type of error go to  C:\Windows\System32\drivers\etc and open the hosts file with notepad. If  you see something like this:

    # Copyright (c) 1993-2009 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host

    # localhost name resolution is handled within DNS itself.
    #    127.0.0.1       localhost
    #    ::1             localhost

    127.0.0.1                     login.facebook.com
    127.0.0.1                     www.facebook.com
    127.0.0.1                     blog.facebook.com
    127.0.0.1                     apps.facebook.com
    127.0.0.1                     en-gb.facebook.com

    (Please note that the bold lines can appear different depending on what windows os you are running)

    then remove the lines with no # as they will cause this error. The web.config file does not exist on any windows xp, vista or 7.

     

    I hope this helps if your hosts file is corrupted though you might want to get a fix from this site: http://support.microsoft.com/kb/972034 and download the microsoft fixit tool.

    Tuesday, September 11, 2012 9:45 PM