locked
Service Unavailable : HTTP Error 503. The service is unavailable. RRS feed

  • Question

  • User-80109782 posted

    Hi i have problem in IIS 7 and classic asp web sites, i received following error.

    Error:

    Service Unavailable :

    HTTP Error 503. The service is unavailable.

     

    1. This is not happened in entire web site, only the particular /reports/ directory.

    2. Same problem has been occurred  in 4 web sites and same directory (/reports/).

    3. Problem has been resolved when i am using HTTPS protocol. but this is only temporary solution.

    4. i reinstalled IIS server, after also i received  same error.

     

    can any one please give me a solution on this issue, this is help full for me. i am facing problem in last 3 months.

    Saturday, November 12, 2011 1:56 AM

Answers

  • User-2064283741 posted

    503 error are (often) reported in the http.sys error logs.

    I am not sure why Mikes guide misses this out.....

    Default path : %systemroot%\system32\logfiles\HTTPERR

     

    Post here extracts of those logs if you are still getting problems.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, November 15, 2011 1:06 PM

All replies

  • User-1672167363 posted

    Hi,

    Start with Mike's Trouble Shooting guide http://forums.iis.net/t/1144449.aspx .

    The first steps are Turn On and Enable "Failed Requests Tracing"

            guide for ASP Errors http://learn.iis.net/page.aspx/565/using-failed-request-tracing-to-troubleshoot-classic-asp-errors/ .

    The use Mike's Guide to track the problems with the Reports directory and code.

    Common problem is the "Application Pools" http://learn.iis.net/page.aspx/624/application-pool-identities/ process mode.

    The solution depends on your fixing the Reports code  permissions Application Pool Settings which are leading to the 503 error

    and failures.

    You may need to load the Reports code in Visual Studio Web Developer to debug and fix the code failures.

    Why have you let this go for 3 months ?

    The IIS 7 Trouble Shooting Forums try and help if you post the errors and messages. 

    Martin

     

     

    Saturday, November 12, 2011 2:17 AM
  • User-655144444 posted
    You should check the event log to say what happened. Re-install IIS does not help.
    Saturday, November 12, 2011 3:58 AM
  • User-80109782 posted
    there is no any error in event viewer. i am looking here... Event Viewer/Custom View/Server Roles/Web Server (IIS)
    Saturday, November 12, 2011 4:25 AM
  • Saturday, November 12, 2011 4:58 AM
  • User-1672167363 posted

    Hi,

    Have you recovered from the 503 errors ?

    Maritn

    Tuesday, November 15, 2011 8:42 AM
  • User-2064283741 posted

    503 error are (often) reported in the http.sys error logs.

    I am not sure why Mikes guide misses this out.....

    Default path : %systemroot%\system32\logfiles\HTTPERR

     

    Post here extracts of those logs if you are still getting problems.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, November 15, 2011 1:06 PM
  • User-80109782 posted

    Hi Rovastar,

     I received following error from this path: %systemroot%\system32\logfiles\HTTPERR

    2011-11-16 04:42:51 192.168.0.11 51328 192.168.0.154 80 HTTP/1.1 GET /reports/ 503 - N/A -
    2011-11-16 04:43:07 192.168.0.11 63327 192.168.0.154 443 - - - - - Timer_ConnectionIdle -
    2011-11-16 04:43:07 192.168.0.11 63337 192.168.0.154 443 - - - - - Timer_ConnectionIdle -
    2011-11-16 04:43:07 192.168.0.11 63338 192.168.0.154 443 - - - - - Timer_ConnectionIdle -
    2011-11-16 04:43:07 192.168.0.11 63339 192.168.0.154 443 - - - - - Timer_ConnectionIdle -
    2011-11-16 04:43:07 192.168.0.11 63336 192.168.0.154 443 - - - - - Timer_ConnectionIdle -
     

    Tuesday, November 15, 2011 11:47 PM
  • User1731374632 posted

    I was having the same issue this morning on my IIS 7.5 server.  To resolve this issue, follow these steps:

    1. Open the Internet Information Services (IIS) Manager
    2. select the Application Pools node under the root node in the left hand side frame. 
    3. Right Click on the DefaultAppPool.  If the service is stopped, start it.  If the service is running, restart it. 
    4. Issue resolved.

    I dont know what caused this issue, but the DefaultAppPool was stopped on my system.  I started the service and afterward I was able to access all of my hosted websites.

     Hope that helps!

    Richie

     

     

    Thursday, February 9, 2012 12:30 PM
  • User377435268 posted

     Having same issue with /reports/ folder. HTTPS doen't work too. Nothing of above helped.

    Tuesday, April 24, 2012 1:17 PM
  • User1057623887 posted

    I was having the same issue this morning on my IIS 7.5 server.  To resolve this issue, follow these steps:

    1. Open the Internet Information Services (IIS) Manager
    2. select the Application Pools node under the root node in the left hand side frame. 
    3. Right Click on the DefaultAppPool.  If the service is stopped, start it.  If the service is running, restart it. 
    4. Issue resolved.

    I dont know what caused this issue, but the DefaultAppPool was stopped on my system.  I started the service and afterward I was able to access all of my hosted websites.

     Hope that helps!

    Richie

     This fixed my problem. Thanks

    Thursday, May 3, 2012 11:41 AM
  • User155175745 posted

    Thank you Richie!

    Your solution is the simplest and only your solution works for me.

     

    Thank you again!

     

    I was having the same issue this morning on my IIS 7.5 server.  To resolve this issue, follow these steps:

    1. Open the Internet Information Services (IIS) Manager
    2. select the Application Pools node under the root node in the left hand side frame. 
    3. Right Click on the DefaultAppPool.  If the service is stopped, start it.  If the service is running, restart it. 
    4. Issue resolved.

    I dont know what caused this issue, but the DefaultAppPool was stopped on my system.  I started the service and afterward I was able to access all of my hosted websites.

     Hope that helps!

    Richie

     

     

    Sunday, June 10, 2012 10:49 PM
  • User1731374632 posted
    Glad to know that my post helped!
    Monday, June 11, 2012 1:35 AM
  • User455367580 posted

    I was having the same issue this morning on my IIS 7.5 server.  To resolve this issue, follow these steps:

    1. Open the Internet Information Services (IIS) Manager
    2. select the Application Pools node under the root node in the left hand side frame. 
    3. Right Click on the DefaultAppPool.  If the service is stopped, start it.  If the service is running, restart it. 
    4. Issue resolved.

    I dont know what caused this issue, but the DefaultAppPool was stopped on my system.  I started the service and afterward I was able to access all of my hosted websites.

     Hope that helps!

    Richie

     

     

    This worked great for me with 7.0. Thanks!
    Wednesday, October 31, 2012 1:48 PM
  • User848332936 posted

    cheers, fixed my problem. TY

    Monday, January 7, 2013 4:45 PM
  • User-831139488 posted

    I had the same error when I moved a site to a new server. My resolution was opening the Advanced Settings... panel of the application pool for the site, and setting "Enable 32-bit Applications" to False.  After re-starting both Application Pool and the site, the error never returned, and the site is functioning as expected.

    Sunday, January 27, 2013 7:01 AM
  • User-228610040 posted

    This should fix your problem:

    In the end, a colleague told me the solution: SQL Reporting Services is answering on the local Reports path! I stopped the service and voila! no more authentication prompt. Instead, a Service unavailable 503 error. This article explained things quite clearly. Even if you stop the service, you have to delete the access control list entry for /Reports with the command netsh http delete urlacl url=http://+:80/Reports

    From:

    http://siderite.blogspot.com/2011/11/windows-authentication-dialog-when.html


    Monday, January 28, 2013 3:58 AM
  • User1529467332 posted

    When trying to install a web site on my test machine (IIS Server) I got Error 503 Service Unavailable, after a long discussion with my seniors and searching on the Internet I found the solution to this problem.

    You can get the help from the following article

    http://www.mindstick.com/Articles/c7eb99f0-5876-43ad-9ece-f8f633ebdb74/?Solving%20IIS%207%20Error%20503%20Service%20Unavailable

    Friday, June 21, 2013 5:10 AM
  • User-31653589 posted

    was having the same issue this morning on my IIS 7.5 server.  To resolve this issue, follow these steps:

    1. <div mce_keep="true">Open the Internet Information Services (IIS) Manager </div>
    2. <div mce_keep="true">select the Application Pools node under the root node in the left hand side frame.  </div>
    3. <div mce_keep="true">Right Click on the DefaultAppPool.  If the service is stopped, start it.  If the service is running, restart it.  </div>
    4. <div mce_keep="true">Issue resolved.</div>

    Thanks,

    This was my problem.  I had forgot that I stopped the specific Application Pool I was using.  Turns out, all I had to do was restart it.

    Thursday, July 18, 2013 2:54 PM
  • User-2117172214 posted

    Reason 1: The HTTP Error 503. The service is unavailable occurs if the Application Pool of the corresponding Wep Application is Stopped or Disabled or Paused

    Reason 2: The given user Identity of Application Pool may be invalid due to expired password or locked

    See this article for perfect fixhttp://www.morgantechspace.com/2013/12/HTTP-Error-503-The-service-is-unavailable.html

    Thursday, December 5, 2013 11:06 PM