locked
Advanced Logging frequently restarting RRS feed

  • Question

  • User-1661181867 posted

    Running IIS 7.5.7600.16385 & Advanced Logging 1.0. I setup Advanced Logging at the server level:

    <logDefinition rollLogFileOnConfigChanges="false" writeLogDataToDisk="true" baseFileName="MyCoolSite" logRaiseTraceEvents="false" enabled="true" logRollOption="Schedule" maxDurationSeconds="86400" maxFileSizeKB="1024" schedule="Daily" publishLogEvent="false">

     It seems that the module is restarting several times (even multiple times per second), as shown in this log file snippit, even though the site does not take any traffic. I also confirmed that the application pool is not recycling:

    #Software: IIS Advanced Logging Module
    #Version: 1.0
    #Start-Date: 2011-08-10 16:38:48.273
    #Filter: (Site Name = MyCoolSite)
    #Fields:  date time c-ip LB-IP cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-substatus sc-win32-status sc-bytes cs-bytes TimeTakenMS cs-version cs(Host) cs(User-Agent) cs(Cookie) cs(Referer)
    #Software: IIS Advanced Logging Module
    #Version: 1.0
    #Start-Date: 2011-08-10 16:38:48.820
    #Filter: (Site Name = MyCoolSite)
    #Fields:  date time c-ip LB-IP cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-substatus sc-win32-status sc-bytes cs-bytes TimeTakenMS cs-version cs(Host) cs(User-Agent) cs(Cookie) cs(Referer)
    #Software: IIS Advanced Logging Module
    #Version: 1.0
    #Start-Date: 2011-08-10 16:38:50.273
    #Filter: (Site Name = MyCoolSite)
    #Fields:  date time c-ip LB-IP cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-substatus sc-win32-status sc-bytes cs-bytes TimeTakenMS cs-version cs(Host) cs(User-Agent) cs(Cookie) cs(Referer)
    #Software: IIS Advanced Logging Module
    #Version: 1.0
    #Start-Date: 2011-08-10 16:38:51.851
    #Filter: (Site Name = MyCoolSite)
    #Fields:  date time c-ip LB-IP cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-substatus sc-win32-status sc-bytes cs-bytes TimeTakenMS cs-version cs(Host) cs(User-Agent) cs(Cookie) cs(Referer)
    #Software: IIS Advanced Logging Module
    #Version: 1.0
    #Start-Date: 2011-08-10 16:38:53.929
    #Filter: (Site Name = MyCoolSite)
    #Fields:  date time c-ip LB-IP cs-username s-sitename s-computername s-ip s-port cs-method cs-uri-stem cs-uri-query sc-status sc-substatus sc-win32-status sc-bytes cs-bytes TimeTakenMS cs-version cs(Host) cs(User-Agent) cs(Cookie) cs(Referer)

     

    I do have Advanced Logging running on many other sites on this box. Any idea what might be causing this?

    Wednesday, August 10, 2011 12:54 PM

All replies

  • User989702501 posted

    In the matter of seconds, this looks weird to me :)

    anything in event log relating to the application pool itself?

    Thursday, August 11, 2011 1:54 AM
  • User-1661181867 posted
    All that is in the Event Log relating to App Pools are informational messages indicating pool recycles and the reason for the recycle. The App Pools are recycling hours apart based on scheduled recycle times or private bytes memory limit has been reached.
    Friday, September 9, 2011 10:50 AM
  • User989702501 posted

    And these recycling info msgs timing has no relevant pattern in relate to the log header generation time?

    I found it weird, I think saw one or two posts with the smiliar behavior, but I can't repro or have actually seen this myself.

    Are there any other related event msgs?

    Monday, September 12, 2011 12:00 AM
  • User1894490842 posted

    I too have this problem.  Makes a real mess of the logs.

    Wednesday, February 15, 2012 12:14 PM
  • User989702501 posted
    No event logs etc to tell you more clues?
    Any specific pattern ?
    Wednesday, February 15, 2012 10:24 PM