none
The server "" timed out. The current request did not complete successfully RRS feed

  • Question

  • Hi,

    I'm using Expression Web 3. When I load up my site from the sites list, i get error "The server "" timed out. The current request did not complete successfully." I deleted the cache of the site as suggested in a previous post. That didn't help. I physically moved the sites directory to somewhere else on the machine and pointed Expression to there. Still same error upon loading the site. I click Ok to the message and cannot Proceed into my site. It's not stored on a server, but stored locally on my machine.

    What can I do?

     

    Thanks,

    Andy

    Friday, September 24, 2010 7:34 PM

All replies

  • It sounds like your site could be trying to publish every time you open it.  IIRC Front Page used to do that to me.  I am using EW4 now and I looked at the site>publishing settings and there did not appear to be an option to change that setting if in fact such a feature exists in your version.  I can't think of any other reason for the server to be involved unless it is a development server or a wamp xamp local server like you would use for PHP.  I hope I did not confuse you.

    Regards,

    MIKE E

     


    "It's like déjà vu all over again." — Yogi Berra
    Friday, September 24, 2010 9:45 PM
  • In EW go to Tools > Application options.
    On the FTP tab, either check or uncheck the box:  Use passive FTP,
    whichever is the case.

    You may also have to change the same setting in Internet Explorer, Tools > Internet Options > Advanced,
    about half way down the advanced options listing.


    Expression Web MVP
    Friday, September 24, 2010 9:47 PM
  • I don't have WAMP, XAMP, etc... installed. I'm no using PHP. This is a ASP.Net site. Could the issue rely in the Web.Config file. Maybe Expression Web is reading some line from within there? I don't know?

     

    Thanks,

    Andy

    Friday, September 24, 2010 9:48 PM
  • Thanks for the ideas guys, keep'em coming!

    Steve Easton, I'm using IE 7. I turned off FTP Passive. I'm using EW3. I turned off FTP Passive, like you suggested. Same error, same issue. 

    Any other ideas?

     

    Thanks,

    Andy


    Friday, September 24, 2010 10:00 PM
  • Have you tried pinging your domain ( website address ) in a command window?

    Start > Run, type CMD and click OK
    In the window that opens type: ping www.yourwebsite.com  or .net as appropriate.
    Does it return a ttl ( time to live ) or does it time out?
    How long has your domain been registered and how long has your hosting account been active?

    Also, if you post your website address, someone can check and see what type server your domain is hosted on.


    Expression Web MVP
    Friday, September 24, 2010 11:11 PM
  • Hi Steve,

    Great reply time. I appreciate it. I'm not sure what you mean by pinging the site since I'm running it locally. Do you mean:


    ping localhost ?

    RESULT:

    That resolved to my MACHINE NAME.COMPANY'S DOMAIN NAME with "::1" displayed as the IP address

    OR

    ping http://localhost ?

    RESULT:

    That resolved to a 63 IP Address and Request Timed Out all 4 times.

    OR

    ping http://localhost.com ?

    That resolved to an 8 IP address and Request Timed Out all 4 times.

    OR

    ping 127.0.0.1 ?

    That resolved all 4 pings in a TTL of 128

    I hope my feedback here makes sense. Let me know what's the next idea guys. Keep'em coming? I even tried disabling my MS SQL services to see if SQL 2008 may be interfering. That was a no go. 

    Thanks,
    Andy

     

    Saturday, September 25, 2010 12:32 PM
  • I have no idea why EW is acting as if you are trying to open a remote site on a server when you are working locally.  Is the site address a plain old path to your local hard drive?

    Have you tried running FPCleaner?  (Download the correct one for your EW version.)

    What happens if you make a new site (say, one of the supplied template sites) on your local drive.  Does that close and reopen without any problem?

    Saturday, September 25, 2010 2:37 PM
  • Thanks for your post Kahty. Yes, the site points locally.

    I ran FPCleaner for EW3 and cleared all related caches..... Still the same issue occurs.

    I made a new test site within EW3 and it works fine. Is this problem something with my existing site? Some corrupt web.config file?

    Thanks,
    Andy

    Saturday, September 25, 2010 3:24 PM
  • Hello Steve,

    Thank you for a concise explanation of 'pinging'. I'd heard the term but never had need to try it.

    Your post prompted me to try it on my sites. Now I know something to try should disaster befall.

    Regards - Andrew C.

    Saturday, September 25, 2010 4:08 PM
  • A web.config file is not run when you are simply opening a local site in EW. It comes into play only when you preview using a server running asp.net (local or remote).

    Open EW, go Site -> Manage Sites List, and look at the list.  Check that the Path of the problematic site really is C:\Documents and Settings\...\My Documents\...\sitename [substitute the actual local disk path for your site] and that the Type is "Local".

     

    Saturday, September 25, 2010 7:25 PM
  • I know this post is a few months old, but I just had the same issue in Expression Web 4 and ultimately solved the problem by going directly to the asp.net temp files under my user and deleting the folder that corresponded to my website that was causing the issue. This folder was buried deep in there so look close to find it.
    Thursday, February 16, 2012 3:32 AM
  • I am having the same problem with EW 4 SP2

    I've tried:

    • EW4FP Cleaner (used all clean options: temp files etc.)
    • Confirmed that the settings for the problematic site and confirmed they are set to LOCAL.
    • Created a new Site (local) and it opens just fine.
    • I TRIED to do a repair on the install but in the Add/Remove programs, when I choose EW 4 i only gives me "uninstall" as an option.

    I tried to find the asp.net files rssweeney5 referred to bu I have no files below my user account (c:\users\<my name>\ ) with the asp.net in the name.

    Monday, October 15, 2012 10:59 PM
  • ASP.net files could only affect things if your site is an asp.net site.  Is it?

    Other than that, since we can't see your PC or your local files, your guess is as good as ours, probably.

    You could try creating a new site, and copying over the old site files, letting EW establish new meta data, etc, for it, and see if things clear up.

    (I assume you've already tried FPCleaner for EW4?)

    Tuesday, October 16, 2012 4:14 AM