none
DoCmd. list of proper responses disappears RRS feed

  • Question

  • For a while now, Access 2010 VBA won't give me the drop-down list of acceptable commands, for example, when I type "OpenForm." (dot)   The list flashes and then disappears. I found this list very helpful in coding properly.  I want to know what is causing this behavior and how to get it back.

    I just rebuilt my database by importing all objects into a new database, thinking perhaps my code was somehow corrupt.  My new database compiles properly but I still don't get the list of acceptable code. 

    Another strange behavior:  When I am typing in VBA, the space bar fails to register and other typos occur that I'm sure I'm not making. Is there something wrong with my project?

    How can I get Access to deliver the drop-down list after the (dot) when creating VBA code?

    Thank you.

    Friday, September 23, 2016 5:23 PM

Answers

  • Yes!  I use a timer to shut down the application after 2 hours idle.  Coincidentally, these problems showed up about the same time I instituted the timer. 

    Can I fix my intellisense without losing the timer?  Is there some easy way to temporarily disable the timer while coding and reactivate it when done? 

    No, you can't "fix" the IntelliSense. That's just how it works. Switch the form to design view. That will turn off the timer.

    One little bit of advice...Never have any form or report open in form/report view while you are writing code. That's a good way to fragment your code. While Access allows VBA editing even in those open forms/reports it's asking for trouble.


    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    • Marked as answer by SammieKay Friday, September 23, 2016 7:42 PM
    Friday, September 23, 2016 7:03 PM

All replies

  • Hi,

    The "dropdown list" you're referring to is called "Intellisense." It will sometimes appear to "act up" if you're using a Timer event on a form. Are you using any Timer event code in your project?

    Friday, September 23, 2016 6:17 PM
  • I'll bet you have a form open that has a timer event. Whenever the timer fires the focus goes off the code window which causes the editor to go idle. Hence, the IntelliSense disappears and any typing you are doing hiccups.

    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals


    Friday, September 23, 2016 6:19 PM
  • Hi,

    The "dropdown list" you're referring to is called "Intellisense." It will sometimes appear to "act up" if you're using a Timer event on a form. Are you using any Timer event code in your project?

    Great minds think alike. Unfortunately I don't type as fast as you, DBGuy. (smile)

    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    Friday, September 23, 2016 6:27 PM
  • Yes!  I use a timer to shut down the application after 2 hours idle.  Coincidentally, these problems showed up about the same time I instituted the timer. 

    Can I fix my intellisense without losing the timer?  Is there some easy way to temporarily disable the timer while coding and reactivate it when done? 

    Friday, September 23, 2016 6:50 PM
  • Yes!  I use a timer to shut down the application after 2 hours idle.  Coincidentally, these problems showed up about the same time I instituted the timer. 

    Can I fix my intellisense without losing the timer?  Is there some easy way to temporarily disable the timer while coding and reactivate it when done? 

    No, you can't "fix" the IntelliSense. That's just how it works. Switch the form to design view. That will turn off the timer.

    One little bit of advice...Never have any form or report open in form/report view while you are writing code. That's a good way to fragment your code. While Access allows VBA editing even in those open forms/reports it's asking for trouble.


    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    • Marked as answer by SammieKay Friday, September 23, 2016 7:42 PM
    Friday, September 23, 2016 7:03 PM
  • Works!  Thank you very much for the answer and the good advice.
    Friday, September 23, 2016 7:42 PM
  • Great minds think alike. Unfortunately I don't type as fast as you, DBGuy. (smile)


    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    Hi Bill,

    Back at you... Cheers!

    Saturday, September 24, 2016 4:18 AM
  • You're welcome!

    Bill Mosca
    www.thatlldoit.com
    http://tech.groups.yahoo.com/group/MS_Access_Professionals

    Monday, September 26, 2016 3:12 PM