locked
Unable to access the System Settings and Reports areas in a new CRM 3.0 installation RRS feed

  • Question

  • I have CRM, SQL and SRS on different servers, all within the same domain.  I am unable to access the System Settings (I'm the Administrator) and the Reports.  From what I've read on Google and Microsoft's sites, there's a configuration problem with connecting to the SRS server.  I can use http://<reportserver>/Reports to see all the available reports. 

    Does anybody know how to solve this problem?   I've seen one solution and that is to reinstall the product.  I've already got a lot customizations done (by my development team) and I really don't want to recreate and rebuild them in a new installation (as that would put a crunch on my timeline). 

    Thanks,

    John Brancaleon

    Monday, February 12, 2007 10:05 PM

Answers

  • Hi John,

    Here's some information from the support engineer. Please let me know if this resolves the issue or not.

    SCOPE

    ======

    Error: An error has occurred. For more information, contact your system administrator.

    Event: Accessing System Settings in CRM.

     

    ASSESSMENT

    ============

    Most of the time when this error occurs with System Settings it has to do with a problem with the reports and accessing them. Can you follow the below instructions and then test and see if you can access reports and system settings.

     

    - Are you able to access reports within CRM? Does an error occur?

    - Are you able to access the calendar in CRM? Does an error occur?

    - Is the error happening for all users?

    - Are you using SSL at all? CRM or Reports website?

     

    1. First open the files rswebapplication.config at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportManager with notepad and search for https://servername.domain.com. Once you find this replace it with http://servername and save and closed the file. Please note that we are changing this address from using SSL to not using SSL by replacing https with http.

     

    2. Next open rsreportserver.config at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer with notepad and search for https://servername.domain.com. Once you find this replace it with http://servername and save and closed the file. Please note that we are changing this address from using SSL to not using SSL by replacing https with http.

     

    3. Then open the registry and modify the following registry values at HKLM | SOFTWARE | Microsoft | Microsoft SQL Server | 80 | Reporting Services to replace https://servername.domain.com with http://servername.

     

    RSVirtualDir - should be http://servername/ReportServer WAVirtualDir - should be http://servername/Reports

     

    4. Now you need to modify the reg entry SQLRSServerURL at HKLM | SOFTWARE | Microsoft | MSCRM from https://servername.domain.com/ReportServer to http://servername/ReportServer

     

    5. Modify the RSReportServer.config file at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer and change the SecureConnectionLevel value from 2 to 0. Note: This may already be set to 0.

     

    6. Finally make one more registry edit at HKLM | SOFTWARE | Microsoft | MSCRM and changed the RSUseSSL value from 1 to 0. Note: This may already be set to 0.

     

    Once complete please make sure that you can view http://servername/Reports before continuing.

    If you can access the above site then make sure you can now access the System Settings within CRM.

     

    NOTE: If you are using Microsoft SQL 2005 you will also need to make the following changes.

    1. Open IIS Manager on the server where SRS is located.

    2. Expand the default Web site and locate the Reports folder.

    3. Right-click on the Reports folder and click Properties.

    4. Click the ASP.NET tab.

    5. Change the drop-down version menu to use version 2.0.

    6. Click OK.

    7. Now and locate the ReportServer folder under the default web site.

    8. Right-click on the ReportServer folder and click Properties.

    9. Click the ASP.NET tab.

    10. Change the drop-down version menu to use version 2.0.

    11. Click OK.

    12. Restart IIS; click Start, click Run, type iisreset and then click OK.

    13. Verify that you can access the Reports Manager by browsing http://servername/Reports.

    14. Lastly, attempt to access System Settings and let me know if you are able to do so.

    -brenda (ISV Buddy Team)

    Tuesday, February 27, 2007 7:51 PM

All replies

  • Hi John,

    Here's some information from the support engineer. Please let me know if this resolves the issue or not.

    SCOPE

    ======

    Error: An error has occurred. For more information, contact your system administrator.

    Event: Accessing System Settings in CRM.

     

    ASSESSMENT

    ============

    Most of the time when this error occurs with System Settings it has to do with a problem with the reports and accessing them. Can you follow the below instructions and then test and see if you can access reports and system settings.

     

    - Are you able to access reports within CRM? Does an error occur?

    - Are you able to access the calendar in CRM? Does an error occur?

    - Is the error happening for all users?

    - Are you using SSL at all? CRM or Reports website?

     

    1. First open the files rswebapplication.config at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportManager with notepad and search for https://servername.domain.com. Once you find this replace it with http://servername and save and closed the file. Please note that we are changing this address from using SSL to not using SSL by replacing https with http.

     

    2. Next open rsreportserver.config at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer with notepad and search for https://servername.domain.com. Once you find this replace it with http://servername and save and closed the file. Please note that we are changing this address from using SSL to not using SSL by replacing https with http.

     

    3. Then open the registry and modify the following registry values at HKLM | SOFTWARE | Microsoft | Microsoft SQL Server | 80 | Reporting Services to replace https://servername.domain.com with http://servername.

     

    RSVirtualDir - should be http://servername/ReportServer WAVirtualDir - should be http://servername/Reports

     

    4. Now you need to modify the reg entry SQLRSServerURL at HKLM | SOFTWARE | Microsoft | MSCRM from https://servername.domain.com/ReportServer to http://servername/ReportServer

     

    5. Modify the RSReportServer.config file at C:\Program Files\Microsoft SQL Server\MSSQL\Reporting Services\ReportServer and change the SecureConnectionLevel value from 2 to 0. Note: This may already be set to 0.

     

    6. Finally make one more registry edit at HKLM | SOFTWARE | Microsoft | MSCRM and changed the RSUseSSL value from 1 to 0. Note: This may already be set to 0.

     

    Once complete please make sure that you can view http://servername/Reports before continuing.

    If you can access the above site then make sure you can now access the System Settings within CRM.

     

    NOTE: If you are using Microsoft SQL 2005 you will also need to make the following changes.

    1. Open IIS Manager on the server where SRS is located.

    2. Expand the default Web site and locate the Reports folder.

    3. Right-click on the Reports folder and click Properties.

    4. Click the ASP.NET tab.

    5. Change the drop-down version menu to use version 2.0.

    6. Click OK.

    7. Now and locate the ReportServer folder under the default web site.

    8. Right-click on the ReportServer folder and click Properties.

    9. Click the ASP.NET tab.

    10. Change the drop-down version menu to use version 2.0.

    11. Click OK.

    12. Restart IIS; click Start, click Run, type iisreset and then click OK.

    13. Verify that you can access the Reports Manager by browsing http://servername/Reports.

    14. Lastly, attempt to access System Settings and let me know if you are able to do so.

    -brenda (ISV Buddy Team)

    Tuesday, February 27, 2007 7:51 PM
  • I have exactly the same problem as this...I cannot access reports, Calendar or System Settings...... CRM 3.0 was working fine until I installed Sharepoint.

     

    I tried to follow the instructions for the resolution but the config files don't have the fields that the resolution describes in them to change.

     

    Interestingly beneath the directory C:\Program Files\Microsoft SQL Server\ have have a directory called MSSQL.1 and MSSQL.2 but not MSSQL

     

    Many thanks

     

    Steve

     

     

    Thursday, May 3, 2007 2:57 PM