locked
Server Error in '/' Application - Security Exception RRS feed

  • Question

  • User1087890051 posted

    Dears,

    I get a problem for the website.
    I can run porperly in my computer, but after I uploaded to server.
    Error happened.

    Actually I am not good at asp.
    Please help me[:'(]

    Thank you

    Sunday, July 15, 2007 10:03 PM

All replies

  • User717450801 posted
    Using your Visual Studio 2005 you should to use Publish Web Site option.
    Monday, July 16, 2007 9:40 PM
  • User-186742165 posted

    Hi

    What happens in your code is the application attempted to perform an operation (reuse NotAllowPartiallyTrustedCallers assemblies) not allowed by the security policy. For testing purposes
    You can try to add this line in your web.config

      <system.web>
        <trust level="Full" originUrl="" />
      </system.web>

    A more prosaic approach is using the custom permission set.

    Here you can get more information

    http://msdn.microsoft.com/en-us/library/tkscy493(VS.80).aspx


    If it's a share host, you probably need to discuss with your hosting provider and get some restrictions on what you can and cannot do.

    Tuesday, July 17, 2007 12:40 AM
  • User1087890051 posted



    Hi XiaoYong Dai,

    Thank you for your reply.
    After I added this script, there is a configuration error..



    thank you for anyone's help.[:)]

    Thursday, July 19, 2007 3:37 AM
  • User-186742165 posted

    Hi

    If you could access the root web.config in %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config, just change the

        <location allowOverride="false">
            <system.web>

    to

        <location allowOverride="true">
            <system.web>

    and it should work.

    If you could not access this file, please contact your web administrator for this problem. Hope it helps

    Thursday, July 19, 2007 4:11 AM
  • User1087890051 posted

    hi~

    I am so sorry.

    I cannot understand.
    That mean I need to change the path?
    %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config

    How?
    I am really sorry.
    I am good at programme.
    But my programmer is on vacation.

    Thank you for your help.

    Thursday, July 19, 2007 9:58 PM
  • User1087890051 posted

    Thank yor for your help.

    I already follow the instruction for these link.

    It is my code in my web.congif.

    <configuration>
    <location allowOverride="false">
    <system.web>
      <securityPolicy>
           <trustLevel name="Full" policyFile="internal" />
           <trustLevel name="High" policyFile="web_hightrust.config" />
           <trustLevel name="Medium" policyFile="web_mediumtrust.config" />
           <trustLevel name="Low" policyFile="web_lowtrust.config" />
           <trustLevel name="Minimal" policyFile="web_minimaltrust.config" />
           <trustLevel name="Custom" policyFile="Web_CustomTrust.config" />
          </securityPolicy>
          <trust level="Custom" originUrl="" />
        <customErrors mode="Off"/>
       </system.web>
    </location>
    <appSettings>
      <add key="MM_CONNECTION_HANDLER_cyconn" value="default_oledb.htm" />
      <add key="MM_CONNECTION_STRING_cyconn" value="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Inetpub\wwwroot\dat\cydat.mdb;Persist Security Info=False" />
      <add key="MM_CONNECTION_DATABASETYPE_cyconn" value="OleDb" />
      <add key="MM_CONNECTION_SCHEMA_cyconn" value="" />
      <add key="MM_CONNECTION_CATALOG_cyconn" value="" />
     
     </appSettings>
    </configuration>

     

     



    I also tried to change <location allowOverride="false"> to true.
    But It still says me Configuration Error.
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: This configuration section cannot be used at this path.  This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

    Source Error:

    Line 2:  <location allowOverride="false">
    Line 3:  <system.web>
    Line 4:   	<securityPolicy>
    Line 5:         <trustLevel name="Full" policyFile="internal" />
    Line 6:         <trustLevel name="High" policyFile="web_hightrust.config" />


    Source File: d:\hosting\repairpda\web.config    Line: 4


    It makes me so worried.

    Friday, July 20, 2007 11:42 PM
  • User-186742165 posted

    I already follow the instruction for these link.

    It is my code in my web.congif.

    <configuration>
    <location allowOverride="false">
    <system.web>
      <securityPolicy>
           <trustLevel name="Full" policyFile="internal" />
           <trustLevel name="High" policyFile="web_hightrust.config" />
           <trustLevel name="Medium" policyFile="web_mediumtrust.config" />
           <trustLevel name="Low" policyFile="web_lowtrust.config" />
           <trustLevel name="Minimal" policyFile="web_minimaltrust.config" />
           <trustLevel name="Custom" policyFile="Web_CustomTrust.config" />
          </securityPolicy>
          <trust level="Custom" originUrl="" />
        <customErrors mode="Off"/>
       </system.web>
    </location>

    Line 2:  <location allowOverride="false">
    Line 3:  <system.web>
    Line 4:   	<securityPolicy>
    Line 5:         <trustLevel name="Full" policyFile="internal" />
    Line 6:         <trustLevel name="High" policyFile="web_hightrust.config" />

    Hi

    Please access the

    %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config file on your server and unlock the configuration like this

    <location allowOverride="true">,

    Otherwise you'll receive this exception since you try to override a locked configuration section.

    Monday, July 23, 2007 3:00 AM
  • User1087890051 posted

    HI~~

    Thank you for your information.
    Really very helpful.

    But there is somewhere makes me confused.
    Actually, my website is in C:\Inetpub\wwwroot, there is also a web.config which is used to link the database.

    But-->
    " Please access the %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config file on your server"

    There mean I need to change and upload this web.config file to my web hosting server?

    And when I learn from the link you send to me.
    They also teach to change some code in the config file.
    But I should change in  %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\
    or C:\Inetpub\wwwroot?

    Thank you.

    Tuesday, July 24, 2007 4:04 AM
  • User-186742165 posted

    Hi

    OK, Let me explain. ASP.NET applications are configured using a set of XML configuration files named web.config.
    These configuration files replace the role of the metabase in IIS and enable configuration changes by simply copying new files onto the server. Configuration files can be placed in several places on a Web server. There is always a top-level web.config file that contains the default settings for all ASP.NET web applications deployed on that machine (in %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\). You can place a web.config file in the root directory of a site that applies to all applications deployed on that site. You can also place web.config files at the top level of a virtual directory or in any subdirectory of an application, and the settings are applied hierarchically, with local configuration files overriding higher-level ones.

    But if you set allowOverride="false" for a section, then it will be locked and don't allow you change. So I suggest you access the top-level web.config (in %windir%\Microsoft.NET\Framework\v2.0.50727\CONFIG\) file and change this property as mentioned, Hope it helps.

    Tuesday, July 24, 2007 7:26 AM
  • User1087890051 posted

    Hi

    May I have your contact information?
    MSN?

    I want directly ask you more detail.
    This project very urgent.

    Please don't mind and please help.

    Thank you very  much!

    Best Regards,
    Or you can send your contact info to my email.

    kiram.designer@gmail.com

    Thanks

    Thursday, July 26, 2007 1:26 AM
  • User-186742165 posted

    Hi 

    You can send me private email. I'm pleasure to be of assistance

    Thursday, July 26, 2007 4:43 AM
  • User-1091210821 posted

    Sorry to jump on this thread and I am going to be a little critical here without naming anyone but some of you as ever seem to take people for a ride. Did you tried the publish option as suggested by someone above, and can I have a look at your web.config and remove all that is suggested above from your web.config. You are putting your file in d:/repair/folder etc ?? Also tell me have you got access to that mapped server drive? If you want to follow what i am going to suggest please let me know or continue as you are. In any case good luck and sorry to be a pain.

    Thursday, July 26, 2007 5:38 AM
  • User-186742165 posted

    Hi naturehermit

    If a caller does not have full trust but still tries to call such a not allow partially trusted callers (APTCA) library, the runtime throws a SecurityException and the caller is not allowed to link to the library. And you can also find my suggestion from this link,

    http://support.microsoft.com/?kbid=555466&SD=tech

    So If you've got another little idea of this problem, we are all ears.

     

    Thursday, July 26, 2007 6:16 AM
  • User-1091210821 posted

    Hi XiaoYong,

     

    What you have suggested is the most obvious explanation, however you have try to reach the problem from a different angle. And because I develop these things everyday, I can most logically see the solution. I am not proclaiming to be the guru, but when the entry you mentioned in web.config created a new message, that should have given you a clue, but you chose not to act on it because you are not thinking from a troubleshooting point of view. I can understand you lack of experience thereof but I feel sick at deliberations and deliberatly doing something is misguiding users. I mean there are lots of threads I dont even touch because I know I dont know much about it despite me having some ideas about whats going on. Anyway if the user comes back with the questions I have asked I will be able to suggest further. No offence, thats why I hate to be in this position but sometimes can resist because I know how much greif it causes to a person who is trying everything he/she can.

    Thursday, July 26, 2007 6:36 AM
  • User-1091210821 posted

    Hi XiaoYong,

     

    What you have suggested is the most obvious explanation, however you have to try to reach the problem from a different angle. And because I develop these things everyday, I can most logically see the solution. I am not proclaiming to be the guru, but when the entry you mentioned in web.config created a new message, that should have given you a clue, but you chose not to act on it because you are not thinking from a troubleshooting point of view. I can understand you lack of experience thereof but I feel sick at deliberations and deliberatly doing something is misguiding users. I mean there are lots of threads I dont even touch because I know I dont know much about it despite me having some ideas about whats going on. Anyway if the user comes back with the questions I have asked I will be able to suggest further. No offence, thats why I hate to be in this position but sometimes can resist because I know how much greif it causes to a person who is trying everything he/she can.

    Thursday, July 26, 2007 6:36 AM
  • User1087890051 posted

     Hi,

    I put the web file into C:\Inetpub\wwwroot

    This is my web.config file in  C:\Inetpub\wwwroot and it connects to my access db.

    <configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
    <appSettings>
            <add key="MM_CONNECTION_HANDLER_cyconn" value="default_oledb.htm" />
            <add key="MM_CONNECTION_STRING_cyconn" value="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Inetpub\wwwroot\dat\cydat.mdb;Persist Security Info=False" />
            <add key="MM_CONNECTION_DATABASETYPE_cyconn" value="OleDb" />
            <add key="MM_CONNECTION_SCHEMA_cyconn" value="" />
            <add key="MM_CONNECTION_CATALOG_cyconn" value="" />
       
        </appSettings>
    </configuration>

    ===============================================================================================================================================

     

    Here is my web.config file in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG

     <?xml version="1.0" encoding="utf-8"?>
    <!-- the root web configuration file -->
    <configuration>
        <!--
            Using a location directive with a missing path attribute
            scopes the configuration to the entire machine.  If used in
            conjunction with allowOverride="false", it can be used to
            prevent configuration from being altered on the machine

            Administrators that want to restrict permissions granted to
            web applications should change the default Trust level and ensure
            that overrides are not allowed
        -->
        <location allowOverride="true">
             <system.web>
                 <securityPolicy>
                    <trustLevel name="Full" policyFile="internal" />
                    <trustLevel name="High" policyFile="web_hightrust.config" />
                    <trustLevel name="Medium" policyFile="web_mediumtrust.config" />
                    <trustLevel name="Low"  policyFile="web_lowtrust.config" />
                    <trustLevel name="Minimal" policyFile="web_minimaltrust.config" />
                </securityPolicy>
                <trust level="Medium" originUrl="" />
            </system.web>
    </location>
          <system.net>
          <defaultProxy>
                <proxy usesystemdefault="true" />
            </defaultProxy>
        </system.net>

        <system.web>
            <authorization>
                <allow users="*" />
            </authorization>

            <browserCaps userAgentCacheKeyLength="64">
                <result type="System.Web.Mobile.MobileCapabilities, System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
            </browserCaps>

            <clientTarget>
                <add alias="ie5" userAgent="Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)" />
                <add alias="ie4" userAgent="Mozilla/4.0 (compatible; MSIE 4.0; Windows NT 4.0)" />
                <add alias="uplevel" userAgent="Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.1)" />
                <add alias="downlevel" userAgent="Generic Downlevel" />
            </clientTarget>

            <compilation>
                <assemblies>
                    <add assembly="mscorlib" />
                    <add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
                    <add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
                    <add assembly="System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
                    <add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    <add assembly="*" />
                </assemblies>
                <buildProviders>
                    <add extension=".aspx" type="System.Web.Compilation.PageBuildProvider" />
                    <add extension=".ascx" type="System.Web.Compilation.UserControlBuildProvider" />
                    <add extension=".master" type="System.Web.Compilation.MasterPageBuildProvider" />
                    <add extension=".asmx" type="System.Web.Compilation.WebServiceBuildProvider" />
                    <add extension=".ashx" type="System.Web.Compilation.WebHandlerBuildProvider" />
                    <add extension=".soap" type="System.Web.Compilation.WebServiceBuildProvider" />
                    <add extension=".resx" type="System.Web.Compilation.ResXBuildProvider" />
                    <add extension=".resources" type="System.Web.Compilation.ResourcesBuildProvider" />
                    <add extension=".wsdl" type="System.Web.Compilation.WsdlBuildProvider" />
                    <add extension=".xsd" type="System.Web.Compilation.XsdBuildProvider" />
                    <add extension=".js" type="System.Web.Compilation.ForceCopyBuildProvider" />
                    <add extension=".lic" type="System.Web.Compilation.IgnoreFileBuildProvider" />
                    <add extension=".licx" type="System.Web.Compilation.IgnoreFileBuildProvider" />
                    <add extension=".exclude" type="System.Web.Compilation.IgnoreFileBuildProvider" />
                    <add extension=".refresh" type="System.Web.Compilation.IgnoreFileBuildProvider" />
                </buildProviders>
                <expressionBuilders>
                    <add expressionPrefix="Resources" type="System.Web.Compilation.ResourceExpressionBuilder" />
                    <add expressionPrefix="ConnectionStrings" type="System.Web.Compilation.ConnectionStringsExpressionBuilder" />
                    <add expressionPrefix="AppSettings" type="System.Web.Compilation.AppSettingsExpressionBuilder" />
                </expressionBuilders>
            </compilation>

            <healthMonitoring>
                <bufferModes>
                    <add name="Critical Notification" maxBufferSize="100" maxFlushSize="20"
                        urgentFlushThreshold="1" regularFlushInterval="Infinite" urgentFlushInterval="00:01:00"
                        maxBufferThreads="1" />
                    <add name="Notification" maxBufferSize="300" maxFlushSize="20"
                        urgentFlushThreshold="1" regularFlushInterval="Infinite" urgentFlushInterval="00:01:00"
                        maxBufferThreads="1" />
                    <add name="Analysis" maxBufferSize="1000" maxFlushSize="100"
                        urgentFlushThreshold="100" regularFlushInterval="00:05:00"
                        urgentFlushInterval="00:01:00" maxBufferThreads="1" />
                    <add name="Logging" maxBufferSize="1000" maxFlushSize="200" urgentFlushThreshold="800"
                        regularFlushInterval="00:30:00" urgentFlushInterval="00:05:00"
                        maxBufferThreads="1" />
                </bufferModes>

                <providers>
                    <add name="EventLogProvider" type="System.Web.Management.EventLogWebEventProvider,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
                    <add connectionStringName="LocalSqlServer" maxEventDetailsLength="1073741823"
                        buffer="false" bufferMode="Notification" name="SqlWebEventProvider"
                        type="System.Web.Management.SqlWebEventProvider,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
                    <add name="WmiWebEventProvider" type="System.Web.Management.WmiWebEventProvider,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a" />
                </providers>

                <profiles>
                    <add name="Default" minInstances="1" maxLimit="Infinite" minInterval="00:01:00"
                        custom="" />
                    <add name="Critical" minInstances="1" maxLimit="Infinite" minInterval="00:00:00"
                        custom="" />
                </profiles>

                <rules>
                    <add name="All Errors Default" eventName="All Errors" provider="EventLogProvider"
                        profile="Default" minInstances="1" maxLimit="Infinite" minInterval="00:01:00"
                        custom="" />
                    <add name="Failure Audits Default" eventName="Failure Audits"
                        provider="EventLogProvider" profile="Default" minInstances="1"
                        maxLimit="Infinite" minInterval="00:01:00" custom="" />
                </rules>

                <eventMappings>
                    <add name="All Events" type="System.Web.Management.WebBaseEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Heartbeats" type="System.Web.Management.WebHeartbeatEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Application Lifetime Events" type="System.Web.Management.WebApplicationLifetimeEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Request Processing Events" type="System.Web.Management.WebRequestEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="All Errors" type="System.Web.Management.WebBaseErrorEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Infrastructure Errors" type="System.Web.Management.WebErrorEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Request Processing Errors" type="System.Web.Management.WebRequestErrorEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="All Audits" type="System.Web.Management.WebAuditEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Failure Audits" type="System.Web.Management.WebFailureAuditEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                    <add name="Success Audits" type="System.Web.Management.WebSuccessAuditEvent,System.Web,Version=2.0.0.0,Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a"
                        startEventCode="0" endEventCode="2147483647" />
                </eventMappings>

            </healthMonitoring>

            <httpHandlers>
                <add path="trace.axd" verb="*" type="System.Web.Handlers.TraceHandler" validate="True" />
                <add path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" validate="True" />
                <add path="*.axd" verb="*" type="System.Web.HttpNotFoundHandler" validate="True" />
                <add path="*.aspx" verb="*" type="System.Web.UI.PageHandlerFactory" validate="True" />
                <add path="*.ashx" verb="*" type="System.Web.UI.SimpleHandlerFactory" validate="True" />
                <add path="*.asmx" verb="*" type="System.Web.Services.Protocols.WebServiceHandlerFactory, System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="False" />
                <add path="*.rem" verb="*" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" validate="False" />
                <add path="*.soap" verb="*" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandlerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" validate="False" />
                <add path="*.asax" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.ascx" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.master" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.skin" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.browser" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.sitemap" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.dll.config" verb="GET,HEAD" type="System.Web.StaticFileHandler" validate="True" />
                <add path="*.exe.config" verb="GET,HEAD" type="System.Web.StaticFileHandler" validate="True" />
                <add path="*.config" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.cs" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.csproj" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.vb" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.vbproj" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.webinfo" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.licx" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.resx" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.resources" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.mdb" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.vjsproj" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.java" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.jsl" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.ldb" verb="*" type="System.Web.HttpForbiddenHandler"  validate="True" />
                <add path="*.ad" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.dd" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.ldd" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.sd" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.cd" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.adprototype" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.lddprototype" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.sdm" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.sdmDocument" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.mdf" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.ldf" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.exclude" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*.refresh" verb="*" type="System.Web.HttpForbiddenHandler" validate="True" />
                <add path="*" verb="GET,HEAD,POST" type="System.Web.DefaultHttpHandler" validate="True" />
                <add path="*" verb="*" type="System.Web.HttpMethodNotAllowedHandler" validate="True" />
            </httpHandlers>


            <httpModules>
                <add name="OutputCache" type="System.Web.Caching.OutputCacheModule" />
                <add name="Session" type="System.Web.SessionState.SessionStateModule" />
                <add name="WindowsAuthentication" type="System.Web.Security.WindowsAuthenticationModule" />
                <add name="FormsAuthentication" type="System.Web.Security.FormsAuthenticationModule" />
                <add name="PassportAuthentication" type="System.Web.Security.PassportAuthenticationModule" />
                <add name="RoleManager" type="System.Web.Security.RoleManagerModule" />
                <add name="UrlAuthorization" type="System.Web.Security.UrlAuthorizationModule" />
                <add name="FileAuthorization" type="System.Web.Security.FileAuthorizationModule" />
                <add name="AnonymousIdentification" type="System.Web.Security.AnonymousIdentificationModule" />
                <add name="Profile" type="System.Web.Profile.ProfileModule" />
                <add name="ErrorHandlerModule" type="System.Web.Mobile.ErrorHandlerModule, System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
            </httpModules>

            <mobileControls sessionStateHistorySize="6" cookielessDataDictionaryType="System.Web.Mobile.CookielessData">
                <device name="XhtmlDeviceAdapters"
                        predicateClass="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlPageAdapter"
                        predicateMethod="DeviceQualifies"
                        pageAdapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlPageAdapter">

                    <control name="System.Web.UI.MobileControls.Panel"             adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlPanelAdapter" />
                    <control name="System.Web.UI.MobileControls.Form"              adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlFormAdapter" />
                    <control name="System.Web.UI.MobileControls.TextBox"           adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlTextBoxAdapter" />
                    <control name="System.Web.UI.MobileControls.Label"             adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlLabelAdapter" />
                    <control name="System.Web.UI.MobileControls.LiteralText"       adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlLiteralTextAdapter" />
                    <control name="System.Web.UI.MobileControls.Link"              adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlLinkAdapter" />
                    <control name="System.Web.UI.MobileControls.Command"           adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlCommandAdapter" />
                    <control name="System.Web.UI.MobileControls.PhoneCall"         adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlPhoneCallAdapter" />
                    <control name="System.Web.UI.MobileControls.List"              adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlListAdapter" />
                    <control name="System.Web.UI.MobileControls.SelectionList"     adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlSelectionListAdapter" />
                    <control name="System.Web.UI.MobileControls.ObjectList"        adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlObjectListAdapter" />
                    <control name="System.Web.UI.MobileControls.Image"             adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlImageAdapter" />
                    <control name="System.Web.UI.MobileControls.ValidationSummary" adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlValidationSummaryAdapter" />
                    <control name="System.Web.UI.MobileControls.Calendar"          adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlCalendarAdapter" />
                    <control name="System.Web.UI.MobileControls.TextView"          adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlTextViewAdapter" />
                    <control name="System.Web.UI.MobileControls.MobileControl"     adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlControlAdapter" />
                    <control name="System.Web.UI.MobileControls.BaseValidator"     adapter="System.Web.UI.MobileControls.Adapters.XhtmlAdapters.XhtmlValidatorAdapter" />
                </device>
                <device name="HtmlDeviceAdapters"
                        predicateClass="System.Web.UI.MobileControls.Adapters.HtmlPageAdapter"
                        predicateMethod="DeviceQualifies"
                        pageAdapter="System.Web.UI.MobileControls.Adapters.HtmlPageAdapter">

                    <control name="System.Web.UI.MobileControls.Panel"             adapter="System.Web.UI.MobileControls.Adapters.HtmlPanelAdapter" />
                    <control name="System.Web.UI.MobileControls.Form"              adapter="System.Web.UI.MobileControls.Adapters.HtmlFormAdapter" />
                    <control name="System.Web.UI.MobileControls.TextBox"           adapter="System.Web.UI.MobileControls.Adapters.HtmlTextBoxAdapter" />
                    <control name="System.Web.UI.MobileControls.Label"             adapter="System.Web.UI.MobileControls.Adapters.HtmlLabelAdapter" />
                    <control name="System.Web.UI.MobileControls.LiteralText"       adapter="System.Web.UI.MobileControls.Adapters.HtmlLiteralTextAdapter" />
                    <control name="System.Web.UI.MobileControls.Link"              adapter="System.Web.UI.MobileControls.Adapters.HtmlLinkAdapter" />
                    <control name="System.Web.UI.MobileControls.Command"           adapter="System.Web.UI.MobileControls.Adapters.HtmlCommandAdapter" />
                    <control name="System.Web.UI.MobileControls.PhoneCall"         adapter="System.Web.UI.MobileControls.Adapters.HtmlPhoneCallAdapter" />
                    <control name="System.Web.UI.MobileControls.List"              adapter="System.Web.UI.MobileControls.Adapters.HtmlListAdapter" />
                    <control name="System.Web.UI.MobileControls.SelectionList"     adapter="System.Web.UI.MobileControls.Adapters.HtmlSelectionListAdapter" />
                    <control name="System.Web.UI.MobileControls.ObjectList"        adapter="System.Web.UI.MobileControls.Adapters.HtmlObjectListAdapter" />
                    <control name="System.Web.UI.MobileControls.Image"             adapter="System.Web.UI.MobileControls.Adapters.HtmlImageAdapter" />
                    <control name="System.Web.UI.MobileControls.BaseValidator"     adapter="System.Web.UI.MobileControls.Adapters.HtmlValidatorAdapter" />
                    <control name="System.Web.UI.MobileControls.ValidationSummary" adapter="System.Web.UI.MobileControls.Adapters.HtmlValidationSummaryAdapter" />
                    <control name="System.Web.UI.MobileControls.Calendar"          adapter="System.Web.UI.MobileControls.Adapters.HtmlCalendarAdapter" />
                    <control name="System.Web.UI.MobileControls.TextView"          adapter="System.Web.UI.MobileControls.Adapters.HtmlTextViewAdapter" />
                    <control name="System.Web.UI.MobileControls.MobileControl"     adapter="System.Web.UI.MobileControls.Adapters.HtmlControlAdapter" />
                </device>
                <device name="UpWmlDeviceAdapters"
                        inheritsFrom="WmlDeviceAdapters"
                        predicateClass="System.Web.UI.MobileControls.Adapters.UpWmlPageAdapter"
                        predicateMethod="DeviceQualifies"
                        pageAdapter="System.Web.UI.MobileControls.Adapters.UpWmlPageAdapter">
                </device>
                <device name="WmlDeviceAdapters"
                        predicateClass="System.Web.UI.MobileControls.Adapters.WmlPageAdapter"
                        predicateMethod="DeviceQualifies"
                        pageAdapter="System.Web.UI.MobileControls.Adapters.WmlPageAdapter">

                    <control name="System.Web.UI.MobileControls.Panel"             adapter="System.Web.UI.MobileControls.Adapters.WmlPanelAdapter" />
                    <control name="System.Web.UI.MobileControls.Form"              adapter="System.Web.UI.MobileControls.Adapters.WmlFormAdapter" />
                    <control name="System.Web.UI.MobileControls.TextBox"           adapter="System.Web.UI.MobileControls.Adapters.WmlTextBoxAdapter" />
                    <control name="System.Web.UI.MobileControls.Label"             adapter="System.Web.UI.MobileControls.Adapters.WmlLabelAdapter" />
                    <control name="System.Web.UI.MobileControls.LiteralText"       adapter="System.Web.UI.MobileControls.Adapters.WmlLiteralTextAdapter" />
                    <control name="System.Web.UI.MobileControls.Link"              adapter="System.Web.UI.MobileControls.Adapters.WmlLinkAdapter" />
                    <control name="System.Web.UI.MobileControls.Command"           adapter="System.Web.UI.MobileControls.Adapters.WmlCommandAdapter" />
                    <control name="System.Web.UI.MobileControls.PhoneCall"         adapter="System.Web.UI.MobileControls.Adapters.WmlPhoneCallAdapter" />
                    <control name="System.Web.UI.MobileControls.List"              adapter="System.Web.UI.MobileControls.Adapters.WmlListAdapter" />
                    <control name="System.Web.UI.MobileControls.SelectionList"     adapter="System.Web.UI.MobileControls.Adapters.WmlSelectionListAdapter" />
                    <control name="System.Web.UI.MobileControls.ObjectList"        adapter="System.Web.UI.MobileControls.Adapters.WmlObjectListAdapter" />
                    <control name="System.Web.UI.MobileControls.Image"             adapter="System.Web.UI.MobileControls.Adapters.WmlImageAdapter" />
                    <control name="System.Web.UI.MobileControls.BaseValidator"     adapter="System.Web.UI.MobileControls.Adapters.WmlValidatorAdapter" />
                    <control name="System.Web.UI.MobileControls.ValidationSummary" adapter="System.Web.UI.MobileControls.Adapters.WmlValidationSummaryAdapter" />
                    <control name="System.Web.UI.MobileControls.Calendar"          adapter="System.Web.UI.MobileControls.Adapters.WmlCalendarAdapter" />
                    <control name="System.Web.UI.MobileControls.TextView"          adapter="System.Web.UI.MobileControls.Adapters.WmlTextViewAdapter" />
                    <control name="System.Web.UI.MobileControls.MobileControl"     adapter="System.Web.UI.MobileControls.Adapters.WmlControlAdapter" />
                </device>
                <device name="ChtmlDeviceAdapters"
                        inheritsFrom="HtmlDeviceAdapters"
                        predicateClass="System.Web.UI.MobileControls.Adapters.ChtmlPageAdapter"
                        predicateMethod="DeviceQualifies"
                        pageAdapter="System.Web.UI.MobileControls.Adapters.ChtmlPageAdapter">

                    <control name="System.Web.UI.MobileControls.Form"              adapter="System.Web.UI.MobileControls.Adapters.ChtmlFormAdapter" />
                    <control name="System.Web.UI.MobileControls.Calendar"          adapter="System.Web.UI.MobileControls.Adapters.ChtmlCalendarAdapter" />
                    <control name="System.Web.UI.MobileControls.Image"             adapter="System.Web.UI.MobileControls.Adapters.ChtmlImageAdapter" />
                    <control name="System.Web.UI.MobileControls.TextBox"           adapter="System.Web.UI.MobileControls.Adapters.ChtmlTextBoxAdapter" />
                    <control name="System.Web.UI.MobileControls.SelectionList"     adapter="System.Web.UI.MobileControls.Adapters.ChtmlSelectionListAdapter" />
                    <control name="System.Web.UI.MobileControls.Command"           adapter="System.Web.UI.MobileControls.Adapters.ChtmlCommandAdapter" />
                    <control name="System.Web.UI.MobileControls.PhoneCall"         adapter="System.Web.UI.MobileControls.Adapters.ChtmlPhoneCallAdapter" />
                    <control name="System.Web.UI.MobileControls.Link"              adapter="System.Web.UI.MobileControls.Adapters.ChtmlLinkAdapter" />
                </device>
            </mobileControls>

            <pages>
                <namespaces>
                    <add namespace="System" />
                    <add namespace="System.Collections" />
                    <add namespace="System.Collections.Specialized" />
                    <add namespace="System.Configuration" />
                    <add namespace="System.Text" />
                    <add namespace="System.Text.RegularExpressions" />
                    <add namespace="System.Web" />
                    <add namespace="System.Web.Caching" />
                    <add namespace="System.Web.SessionState" />
                    <add namespace="System.Web.Security" />
                    <add namespace="System.Web.Profile" />
                    <add namespace="System.Web.UI" />
                    <add namespace="System.Web.UI.WebControls" />
                    <add namespace="System.Web.UI.WebControls.WebParts" />
                    <add namespace="System.Web.UI.HtmlControls" />
                </namespaces>

                <controls>
                    <add tagPrefix="asp" namespace="System.Web.UI.WebControls.WebParts" assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                </controls>
            </pages>

            <siteMap>
                <providers>
                    <add siteMapFile="web.sitemap" name="AspNetXmlSiteMapProvider"
                        type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                </providers>
            </siteMap>

            <urlMappings enabled="true" />

            <webControls clientScriptsLocation="/aspnet_client/{0}/{1}/" />

            <webParts>
                <personalization>
                    <providers>
                        <add connectionStringName="LocalSqlServer"
                            name="AspNetSqlPersonalizationProvider" type="System.Web.UI.WebControls.WebParts.SqlPersonalizationProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
                    </providers>

                    <authorization>
                        <deny users="*" verbs="enterSharedScope" />
                        <allow users="*" verbs="modifyState" />
                    </authorization>
                </personalization>

                <transformers>
                    <add name="RowToFieldTransformer" type="System.Web.UI.WebControls.WebParts.RowToFieldTransformer" />
                    <add name="RowToParametersTransformer" type="System.Web.UI.WebControls.WebParts.RowToParametersTransformer" />
                </transformers>
            </webParts>

        </system.web>
    </configuration>

    =========================================================================================================================================

    And my asp.net is 2.0 version

    What can I do?
    The problem still here. After upload all files in C:\Inetpub\wwwroot cannot be seen on the internat.

    here is my website.
    www.repairHppda.com

    Thank you for your help

     

    Thursday, August 2, 2007 12:53 AM
  • User-186742165 posted

     Hi,

    I put the web file into C:\Inetpub\wwwroot

    This is my web.config file in  C:\Inetpub\wwwroot and it connects to my access db.

    <configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
    <appSettings>
            <add key="MM_CONNECTION_HANDLER_cyconn" value="default_oledb.htm" />
            <add key="MM_CONNECTION_STRING_cyconn" value="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Inetpub\wwwroot\dat\cydat.mdb;Persist Security Info=False" />
            <add key="MM_CONNECTION_DATABASETYPE_cyconn" value="OleDb" />
            <add key="MM_CONNECTION_SCHEMA_cyconn" value="" />
            <add key="MM_CONNECTION_CATALOG_cyconn" value="" />
       
        </appSettings>
    </configuration>

    ===============================================================================================================================================

    Hi

    Please change the quote like this, means the code can do anything in a trust environment

    <configuration>
    <system.web>
        <customErrors mode="Off"/>


        <trust level="Full" originUrl="" />

    </system.web>
    <appSettings>
            <add key="MM_CONNECTION_HANDLER_cyconn" value="default_oledb.htm" />
            <add key="MM_CONNECTION_STRING_cyconn" value="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Inetpub\wwwroot\dat\cydat.mdb;Persist Security Info=False" />
            <add key="MM_CONNECTION_DATABASETYPE_cyconn" value="OleDb" />
            <add key="MM_CONNECTION_SCHEMA_cyconn" value="" />
            <add key="MM_CONNECTION_CATALOG_cyconn" value="" />
       
        </appSettings>
    </configuration>

    Thursday, August 2, 2007 1:42 AM
  • User1087890051 posted

     Hi,
    Thank you for your reply.
    I followed your instruction. But Configuration Error is happened.


    Server Error in '/' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: This configuration section cannot be used at this path.  This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

    Source Error:


    Line 2:  <system.web>
    Line 3:      <customErrors mode="Off"/>
    Line 4:      <trust level="Full" originUrl="" />
    Line 5:  </system.web>
    Line 6:  <appSettings>

     

     

     

    Thursday, August 2, 2007 2:02 AM
  • User-186742165 posted

    Here is my web.config file in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG

     <?xml version="1.0" encoding="utf-8"?>
    <!-- the root web configuration file -->
    <configuration>
        <!--
            Using a location directive with a missing path attribute
            scopes the configuration to the entire machine.  If used in
            conjunction with allowOverride="false", it can be used to
            prevent configuration from being altered on the machine

            Administrators that want to restrict permissions granted to
            web applications should change the default Trust level and ensure
            that overrides are not allowed
        -->
        <location allowOverride="true">
       

    Hi

    Is it probable that you are not using the .NET Framework version 2.0.50727?

    Thursday, August 2, 2007 2:18 AM
  • User1087890051 posted

     Hi,

    yes, we are using .NET Framework version 2.0.50727

    Thursday, August 2, 2007 3:14 AM
  • User-186742165 posted

    Hi

    It seems that this website always lock access to config section, no matter what is done, May be it's a simple idea but doesn't occur.

    BTW, for urgent problem, I'll suggest you required a live observatio .

    Thursday, August 2, 2007 4:02 AM
  • User1087890051 posted

     Hi,

    How can I get a live observatio?

    Could you help online?

    Best Regards,

    Thursday, August 2, 2007 4:17 AM
  • User-186742165 posted

    Hi

    For live assistance, you can directly call our Microsoft Support Engineer through Microsoft Customer Support Services by contacting us at 1-(800)936-5800

    Or choosing the following link
    http://support.microsoft.com/common/international.aspx?rdpath=fh;en-us;cntactms

    Thank you for your understanding.

    Thursday, August 2, 2007 4:25 AM
  • User-5805606 posted

    I found the solution XD few years later xDD but here i found the link to msdn there is the code

    <trust
    level="Full"
    originUrl=""
    processRequestInApplicationTrust="true"
    />

    Thursday, October 23, 2014 6:31 AM