locked
IIS express worker process has stopped working RRS feed

  • Question

  • I am using visual studio 2013 & IIS express 8.0. when I am building my .net application, project is getting build successfully. but getting runtime error of IIS express worker process has stopped working. could you please help me out. Please find the attached screenshot for reference. I did the basic troubleshooting but no luck :(

    1) system restart

    2) IIS admin restart

    3) checked all IIS seetings in control panel/add or remove programs--> left side turn windows features on & off--->IIS--> expand featues & check all the IIS related fields

    Thursday, February 18, 2016 7:04 AM

Answers

  • Hi prakashITsoftware,

    I also run Visual Studio 2013 & IIS Express 8.0 on my computer and I don't get this error.

    Please create a new website project to check whether all projects have this issue or just this specific project has this issue.

    If just this specific project, please try debug your application code to check whether it is caused by your code. And you also can create a new website and then move the original project files to the new website one by one. It can help us make sure which file causes this issue.

    If all projects have this issue, please try uninstall and reinstall IIS Express 8 to check whether it can fix this issue.

    In addition, there has higher version of IIS Express. Please uninstall your IIS Express 8 and install the IIS Express 10 to check whether this problem still exist.

    https://www.microsoft.com/en-us/download/details.aspx?id=48264

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Thursday, February 25, 2016 7:13 AM
    • Marked as answer by Weiwei Cai Friday, February 26, 2016 8:56 AM
    Friday, February 19, 2016 5:23 AM

All replies

  • Hi prakashITsoftware,

    I also run Visual Studio 2013 & IIS Express 8.0 on my computer and I don't get this error.

    Please create a new website project to check whether all projects have this issue or just this specific project has this issue.

    If just this specific project, please try debug your application code to check whether it is caused by your code. And you also can create a new website and then move the original project files to the new website one by one. It can help us make sure which file causes this issue.

    If all projects have this issue, please try uninstall and reinstall IIS Express 8 to check whether it can fix this issue.

    In addition, there has higher version of IIS Express. Please uninstall your IIS Express 8 and install the IIS Express 10 to check whether this problem still exist.

    https://www.microsoft.com/en-us/download/details.aspx?id=48264

    Best Regards,
    Weiwei

    • Proposed as answer by Weiwei Cai Thursday, February 25, 2016 7:13 AM
    • Marked as answer by Weiwei Cai Friday, February 26, 2016 8:56 AM
    Friday, February 19, 2016 5:23 AM
  • Hi Weiwei,

    Iam having same issue with all my projects.

    I tried steps you mentioned, But no Help

    • I reinstalled IIS
    • I even re modified VS 2017 .

     None of them worked, I installed DebugDiag but no logs for crash appears. .

    Please Help.

    Saturday, August 26, 2017 10:36 AM
  • Hi JatinsCode,

    Since this thread has been closed for a long time, please create a new thread on our forum to describe your problem detailed. It could let other communities who familiar with this issues to help you solve the problem. Thanks for your understanding.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 28, 2017 2:13 AM