none
Greyed out scrollbar when setting rc:Toolbar false

    Question

  • Hi,
    I am running an SSRS report in Internet Explorer through the reportserver interface.

    I don't want to see the toolbar so I add "rc:Toolbar=false" to the URL. When I do this, a vertical scrollbar appears. How can I get rid of this?

    /Marcus


    Wednesday, January 11, 2017 3:14 PM

Answers

  • Hi guys, here is an update after I made some more testing. 

    I made a copy of the default stylesheet and in that file I set all toolbar items to "display: none" like below:

    .ToolbarPageNav
    {
    display: none;
    }

    Then I set the toolbar borders to 0 px like below:

    .ToolBarBackground
    {
    background-image: url(Reserved.ReportViewerWebControl.axd?OpType=StyleSheetImage&Name=toolbar.jpg);
    background-color:#dee7f2;
    border-bottom: 0px solid #a4b7d8;
    border-nbsp;0px solid #a4b7d8;
    border-
    border-right: none;
    }

    And finally I referenced this stylesheet in my URL by adding  "&rc:stylesheet=rs" where rs is the name of my new stylesheet.

    That seems to be working. Thanks for your help!

    /Marcus

    Thursday, January 12, 2017 10:33 AM

All replies

  • Hi,
    I am running an SSRS report in Internet Explorer through the reportserver interface.

    I don't want to see the toolbar so I add "rc:Toolbar=false" to the URL. When I do this, a vertical scrollbar appears. How can I get rid of this?

    /Marcus


    try this 

    http://localhost/ReportServer?\Report+Project1\Report3&rc:Command=Render&rs:Format=HTML3.2&rc:LinkTarget=_self

     

    Thanks

    ______________________________________________________________________

    Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers


    • Edited by SequelMate Wednesday, January 11, 2017 3:30 PM
    Wednesday, January 11, 2017 3:23 PM
  • Hi emcus,

    In your scenario, the grey vertical scroll bar appears when you append "rc:Toolbar=false" to the URL, right?

    Which version of SSRS and IE browser do you use? Does this problem exist if you view other reports? Also, please input the same URL in other version of IE browser for a test.

    Also please try to set the compatibility in IE browser and try again.

    1. Open IE browser
    2. Press F12
    3. Under "Emulation" tab, change the "Document mode" to "Edge"

    Besides, you can try another solution to hide the toolbar. Find the ReportViewer.aspx file(Default location: C:\Program Files\Microsoft SQL Server\<instance name>\Reporting Services\ReportServer\Pages). Add the code like below:

    <style>
      .ToolBarButtonsCell{
      	display: none;
      }
      </style>
    
      <script>
      window.onload = function(){
      	var intv = setInterval(disableSel, 100);
      };
      function disableSel()
      {
      	document.querySelector("select[id^='ReportViewerControl']").disabled = true;
      }
      </script>

    Reference: Hiding Toolbar in SSRS

    If you have any question, please feel free to ask.

    Thanks,
    Yuliana Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 12, 2017 7:17 AM
  • Hi SequelMate,

    This gives me

    "You have attempted to use a rendering extension that is either not registered for this report server or it is not supported in this edition of Reporting Services"

    /Marcus

    Thursday, January 12, 2017 8:35 AM
  • Hi Yuliana

    • Yes, the grey vertical scroll bar appears when I append "rc:Toolbar=false" to the URL
    • I am using SSRS 2014 and IE11
    • Pressing F12 in IE and going through the Document Modes I discover that 8 works fine for the report and removes the scroll bar. I have tried to set this in ReportViewer.aspx:
      <meta http-equiv="X-UA-Compatible" content="IE=8">
      But it doesn't seem to have any effect when viewing the report in IE.
    • I tried hiding the toolbar according to your suggestion which worked but instead added a blue line at the top of the browser.

    Please let me know if you have any other suggestions. The Document Mode idea is interesting, maybe I just didn't apply the correct modification to the ReportViewer file?

    /Marcus

    Thursday, January 12, 2017 8:55 AM
  • Hi guys, here is an update after I made some more testing. 

    I made a copy of the default stylesheet and in that file I set all toolbar items to "display: none" like below:

    .ToolbarPageNav
    {
    display: none;
    }

    Then I set the toolbar borders to 0 px like below:

    .ToolBarBackground
    {
    background-image: url(Reserved.ReportViewerWebControl.axd?OpType=StyleSheetImage&Name=toolbar.jpg);
    background-color:#dee7f2;
    border-bottom: 0px solid #a4b7d8;
    border-nbsp;0px solid #a4b7d8;
    border-
    border-right: none;
    }

    And finally I referenced this stylesheet in my URL by adding  "&rc:stylesheet=rs" where rs is the name of my new stylesheet.

    That seems to be working. Thanks for your help!

    /Marcus

    Thursday, January 12, 2017 10:33 AM
  • .ToolbarPageNav
    {
    display: none;
    }

    Then I set the toolbar borders to 0 px like below:

    .ToolBarBackground
    {
    background-image: url(Reserved.ReportViewerWebControl.axd?OpType=StyleSheetImage&Name=toolbar.jpg);
    background-color:#dee7f2;
    border-bottom: 0px solid #a4b7d8;
    border-nbsp;0px solid #a4b7d8;
    border-
    border-right: none;
    }

    And finally I referenced this stylesheet in my URL by adding  "&rc:stylesheet=rs" where rs is the name of my new stylesheet.

    Hi emcus,

    Glad to hear that you have resolved your issue. Would you please kindly mark the corresponding reply as an answer so that some other users having similar requirement can find the valid solution easily.

    Thanks,
    Yuliana Gu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 13, 2017 1:56 AM