locked
Launching esp in -dev mode RRS feed

  • Question

  • Hi all, I know this is a very stupid question but I have never really used the command line in windows (XP) and am having trouble launching esp in the -dev mode.

    In the command line I enter:

    "C:\Program Files\Microsoft ESP\1.0\esp.exe"

    To launch esp.  Should the -dev be included somewhere in this? or am i doing it completely wrong?

    Sorry for wasting your time on something so trivial and thanks for any responses.
    Wednesday, June 25, 2008 4:09 PM

Answers

  • "Ah ok I think that's working now.  I'm trying to create a mission and am getting confused because the sdk documentation says a diagnostic window for simConnect should appear on launching but this does not occurr.  It then says the object placement tool should be available from the Tools menu in ESP?  I have edited the dll.xml as it describes."

    To have the console window for SimConnect pop up, you need to edit the SimConnect.ini file. More information about that can be found here:

    http://msdn.microsoft.com/en-us/library/cc526983.aspx#Thesimconnectinifile

    Best regards,
    Wednesday, June 25, 2008 10:05 PM

All replies

  • You're not wasting anyone's time.

    Yes, esp.exe -dev

    You could also add the -dev inside your shortcut if you have one.  Just go to the shortcut's properties target line.

    Bobby
    Wednesday, June 25, 2008 4:22 PM
  • Thanks for such a fast response. 

    When I use "C:\Program Files\Microsoft ESP\1.0\esp.exe -dev" it says it doesn't recognise it and when I use "C:\Program Files\Microsoft ESP\1.0\esp.exe" -dev it just loads the normal mode?  The same happens with the shortcut.

    Thanks  
    Wednesday, June 25, 2008 5:19 PM
  • I'm no expert with the cmd line but, I don't think you need the parenthesis.  To make it more simple, just go to the directory where your esp.exe is located.  Then for dev mode, just type
    esp.exe -dev
    That should do it.

    Bobby

    Wednesday, June 25, 2008 5:33 PM
  • Sorry I don't quite understand what you mean?  The parenthesis are neccessary as the path contains spaces, without them the cmd line only reads 'C:\Program'.

    Thanks
    Wednesday, June 25, 2008 5:59 PM
  • Hi,

    Sorry, I wasn't being very clear.   When you use "C:\Program Files\Microsoft ESP\1.0\esp.exe -dev", it'll say something like, is not recognized as an internal or external command.  So what I was trying to suggest was to actually go to your esp directory.  In your case, something like this:
    >C:
    >cd "C:\Program Files\Microsoft ESP\1.0"
    >esp.exe -dev

    I hope that helps
    Bobby

    Wednesday, June 25, 2008 6:13 PM
  • I tried what you said but it still seems to just load the normal mode.  I should have more menu's etc when it loads in the -dev mode? Any more suggestions?

    Thanks for all your help
    Wednesday, June 25, 2008 6:30 PM
  • When you run in dev mode, it is just like running fsx.  You don't get more menus, its just that the items in the menus are not gray'd out.  For example, in dev mode you can select aircraft.  In normal mode you can't.

    Bobby
    Wednesday, June 25, 2008 6:42 PM
  • Ah ok I think that's working now.  I'm trying to create a mission and am getting confused because the sdk documentation says a diagnostic window for simConnect should appear on launching but this does not occurr.  It then says the object placement tool should be available from the Tools menu in ESP?  I have edited the dll.xml as it describes.

    Sorry the problem is escalating! Thanks 
    Wednesday, June 25, 2008 7:02 PM
  •  "C:\Program Files\Microsoft ESP\1.0\esp.exe" -dev
    Wednesday, June 25, 2008 8:13 PM
  • "Ah ok I think that's working now.  I'm trying to create a mission and am getting confused because the sdk documentation says a diagnostic window for simConnect should appear on launching but this does not occurr.  It then says the object placement tool should be available from the Tools menu in ESP?  I have edited the dll.xml as it describes."

    To have the console window for SimConnect pop up, you need to edit the SimConnect.ini file. More information about that can be found here:

    http://msdn.microsoft.com/en-us/library/cc526983.aspx#Thesimconnectinifile

    Best regards,
    Wednesday, June 25, 2008 10:05 PM
  • Thanks for all the help so far it's been great! I looked at the link and found I didn't even have the simconnect.ini file in the correct folder.  I corrected that and it now launches a simconnect diagnostic output window.   I'm still stuck as i'm trying to follow this part of the mission creation tutorial...

    "Testing for a Successful Setup: You will know that the tool has been correctly installed when you start up ESP. Do this from the command line prompt: ESP -dev, as this will ensure that you are in dev mode while developing missions (so the menu options you will need are available). Refer to the Solution Deployment section of the SDK Overview for more details.

    First, there will be a diagnostic window for SimConnect that should report that the dll has been launched. Second, the tool will be available in the Tools menu of ESP."

    I have edited the dll.xml file as it describes before this section but I get no diagnostic window from simconnect saying the dll has been launched and I have no idea where the tools menu of esp is?

    Thanks

    Thursday, June 26, 2008 8:49 AM
  • Hey everyone my problems are now solved!  It was the missing simconnect.ini file that was the main problem so thanks for everyones help and suggestions.

    Friday, June 27, 2008 9:15 AM