locked
what is the exact meaning of Minimum supported client and Minimum supported server?

    Question

  • Hi, dear all,
     
    I am not clear about the "Requirements" of each API on MSDN. For example,  SwapChainBackgroundPanel.CreateCoreIndependentInputSource says that:

     

    Requirements

    Minimum supported client

    Windows 8.1

    Minimum supported server

    Windows Server 2012 R2

    Namespace

    Windows.UI.Xaml.Controls
    Windows::UI::Xaml::Controls [C++]

    Metadata

    Windows.winmd

     

    The "Minimum supported client" is Windows 8.1. Does it mean that:

    a). It must be run on a Win8.1 env? And/Or
    b). The compile env must be a Win8.1 one?

    c). If I installed the latest SDK, is it possible that we compile it on a Win8 or even older system, such as Win7 (given that the SDK is supported to be installed on Win7)?

     

    Thank you all very much!




    • Edited by B0L Monday, January 13, 2014 9:38 AM
    Monday, January 13, 2014 8:19 AM

Answers

All replies