locked
Default 100% Size Logo (150x150 px) Submission Error

    Question

  • Hello, i have some troubles changing the default sized logo of my app in Visual Studio 2012.

    I am fairly certain i am respecting all the guidelines:

    -150 x 150 px size

    -png or jpg format (tried with both).

    I get an error every each and every time i try to replace the default logo with the one i made.
    Also, it's quite curious that if i create a new app, delete its logo and then put the default one back, i get the same error!

    The only viable workaround involves manually replacing the logo.png file in the Assets directory, avoiding to replace it in Visual Studio.

    Am I doing something wrong? It really does feel like a bug of the program.

    Saturday, December 8, 2012 2:16 PM

All replies

  • What is the error? Where are you seeing it? How is the imaged named? How are you referring to it in the manifest wizard?
    Saturday, December 8, 2012 2:24 PM
  • Hello, and thanks for replying.

    I am seeing the error in the appxmanifest section, although nothing shows up in the error list window.

    I have uploaded a screenshot: http://i.imgur.com/kYnk5.jpg Unfortunately, my VS is in italian, so it may not make much sense to you :x

    When i hover the mouse on the red error symbol, it does tell me "The image's asset or a related field contains one or more errors. Select it and correct it", but doesn't mention anything specific.

    I have tried several images, both in format\color depth\ weight and also names, including "Logo.png" used by the default Logo, to no avail.

    And, if i understand your question correctly, I just select the image via the small grey button under it.

    Thanks again!

    Saturday, December 8, 2012 3:03 PM

  • Hi, I have only one wild guess here:  

    Is the file still open in Photoshop?  Could Photoshop be preventing VS from accessing the file?

    Try saving the file and closing it in Photoshop before using the manifest wizard to reference it.
    • Edited by jrboddie Saturday, December 8, 2012 8:03 PM
    Saturday, December 8, 2012 8:01 PM
  • Unfortunately it's not that :x I also tried building the images with GIMP and Paint, again with no results.
    Tuesday, December 11, 2012 11:18 AM